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Evaluating current and potential clinical sites: A spatial analysis of the UCSD Student-Run Free 

Clinic Project 

A Student’s Guide

 

 

Introduction: 

After 18 years of service in the same location, the UCSD Free Clinic Project (Free Clinic) had to 

close one its four clinic sites. Several hundred patients were faced with the challenge of 

commuting long distances to another clinic, and even losing access to care. Although 

unfortunate, this became an opportunity for the Free Clinic to examine where its patients live, the 

distances they travel to clinic, and determine new locations for a clinic.  To complete this 

examination, the Free Clinic performed a spatial analysis—mapping patients and clinic 

locations—using specialized Geographic Information Systems (GIS) software.  

 

Spatial analyses have been used previously to help place new medical facilities, and evaluate 

patient populations, however little has been reported on the use of such analyses by free clinics, 

and the practical approach to selecting a new clinic location. The ultimate importance of spatial 

analyses lies in the fact that “primary health care clinics are bound to the patients they serve by 

geography,” and this ‘geography’ is not limited to merely the shape of the land but encompasses 

the whole of the lived environment.1  This ‘geography’ can be so many things from air quality, 

or school districts, to bus routes and crime rates; in order to provide efficient and effective care, 

providers must examine this ‘geography’.  Therefore, what follows is a document that intends to 

describe the process and tools used in the Free Clinic’s analysis so that other students might be 

able to take up their own spatial analysis project. 

 

Getting Started: 

The examination reported here focused on geography by means of distance and travel times, 

however any number of factors (street lights, crime, bus routes, schools, etc) could be evaluated 

in a spatial analysis, as mentioned above. For any ‘geography’ being analyzed, the strength of a 

spatial analysis is in examining relationships in space, and to that end starts with creating a map. 

 

The Free Clinic serves a vulnerable population of immigrants, many of whom are 

undocumented. When creating the map, it was decided that it should be created in a way that 

keeps its contents protected. The mapping software, ArcMap (10.4, ESRI, Redlands, CA), was 

chosen as it was available through UCSD, free for students, has numerous tools and resources to 

complete this project, and being desktop-based limits the possibilities for inadvertent exposure of 

patient information. There are a variety of other GIS software packages that could be used, 

ranging from free online resources like QGIS, GRASS, uDIG, Google Maps, and Google Earth, 

                                                 
1 Bazemore A, Diller P, Carrozza M. The Impact of a Clinic Move on Vulnerable Patients with Chronic Disease: A 

Geographic Information Systems (GIS) Analysis. J Am Board Fam Med. 2010; 23:128-130 



to other commercial alternatives.2, 3, 4, 5 The following information pertains specifically to the 

usage of ArcMap by UCSD students. 

 

The ArcGIS software, only for Windows Platforms, is available through UCSD’s Educational 

Technology Services.6  UCSD Students must fill out a verification form with their name, campus 

email address, and Student ID #; after verifying students’ eligibility, Educational Technology 

Services will issue an install code.7 You can check the system requirements with the software 

developer (Esri); all of the work of this project was performed on a desktop PC.8  With the install 

code, the software can be download from the developer’s website.9 ArcGIS is a very complex 

system (entire courses and certifications are offered in various GIS software systems) and this 

guide is intended to only cover basic usage; for most problems the GIS forums and the software 

tutorials will likely yield an answer.  

 

Using ArcMap: 

ArcMap utilizes layers to display a variety of data. Layers typically store their data in shapefiles, 

and shapefiles are made up of several different files (.cpg, .dbf, .prj, .sbn, .sbx, .shp) combined to 

create the data displayed in ArcGIS (see Appendix A).  Shapefiles can be downloaded from 

numerous sources of GIS data, and many basic shapefiles are available through Esri. This project 

was focused specifically on the Free Clinic in San Diego, so the shapefiles used were obtained 

from the city of San Diego which publishes a multitude of GIS information online through 

SanGIS and their Regional Data Warehouse.  Information and shapefiles available through 

SanGIS include files such as zoning, land use, parcels, bike paths and roadways, even the 

location of lamp posts.10 Shapefiles of road and transit data were used predominantly for this 

analysis.  

 

ArcMap requires data be loaded into the software before it can be analyzed. As mentioned, data 

is commonly in the form of shapefiles, but other formats such as Excel tables can also be used. 

For the analysis performed, the data was patient addresses collected from their electronic medical 

record which were extracted to an Excel spreadsheet stored on a secured server. The Excel data 

containing the addresses was loaded into ArcMap (See Appendix B for more information on how 

to add data into ArcMap, see Appendix C for an example). While the data is stored in ArcMap, it 

is not displayed on the map because the software can’t plot street level addresses yet. To actual 

plot the addresses requires a process called geocoding which takes the street number format in 

the table and turns it into plottable coordinates akin to latitude, longitude coordinates or (X, Y) 

that can be plotted on a map.  

 

Geocoding: 

                                                 
2 https://www.qgis.org/en/site/  
3 https://www.google.com/maps  
4 https://grass.osgeo.org/  
5 http://udig.refractions.net/  
6 https://acms.ucsd.edu/services/software/available-software/esri-arcgis.html 
7 https://software-web.ucsd.edu/contact_us.php#Contact%20UCSD%20Software%20Distribution 
8 https://desktop.arcgis.com/en/arcmap/10.4/get-started/setup/arcgis-desktop-system-requirements.htm 
9 https://acms.ucsd.edu/_files/services/software/ArcGIS_Student_Version%2010.pdf 
10 http://www.sangis.org/download/index.html 
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Geocoding is the process of taking street addresses and converting to geographic coordinates 

akin to latitude and longitude that can be used to place markers on a map. An Address Locator is 

the main tool behind geocoding and uses GIS or other datasets containing reference information 

necessary for this process. There are commercial services that will geocode addresses, but most 

GIS software can also geocode addresses. ArcMap is capable of geocoding and because of the 

vulnerabilities of our patient population and the prices associated with many geocoding services, 

the Free Clinic opted to create an address locator and geocode the addresses within ArcMap.   

 

Building an Address Locator is the first step in this geocoding process and is relatively straight 

forward in ArcMap. Obtain the reference data that will be used to build the locator. For the Free 

Clinic’s analysis a shapefile of all San Diego roads was used as it contained all the necessary 

reference data for a simple data locator. Multiple shapefiles can also be used to build a composite 

Address Locator. Depending on the level of detail and accuracy required, more or less reference 

data may be needed, e.g., analyses looking at a state level vs county level vs zip codes vs street 

addresses will require different information (See Appendix D for more information on resolution 

and GIS data security).  

 

To begin building an address locator, open the “Create Address Locator” tool and fill out the 

required fields (ArcToolbox > Geocoding Tools > Create Address Locator). As mentioned 

previously, there are several styles of locators that can be used based on the reference data 

available, and the resolution needed. The sensitivity of the Address Locator can be adjusted, 

which controls the parameters of matching addresses. Strict parameters will require more exact 

matches, and loose parameters will allow more partial matches. After successfully creating an 

Address Locator it can be used for a variety of different analyses, particularly geocoding (see 

Appendix E for more information on building an address locator). For troubleshooting and other 

help visit ArcGIS Desktop online for support.11 

 

For the Free Clinic’s analysis, the table of patient addresses was geocoded using an address 

locator within ArcMap. This limited exposure of patient data to outside parties and helped 

maintain confidentiality. Given that the Free Clinic was looking at street level information in the 

form of addresses, a Dual Range Address Locator capable of finding the street and determining 

where along its length the address is located was used.  This locator did not contain enough data 

to determine where an apartment might be located within a complex, but could determine the 

location of the complex along the street, and overall has a modest error of several feet. 

 

Basic tools: 

Once geocoded data is loaded into the map, it can now be manipulated and analyzed. Many tools 

are available for different types of analysis; this guide is not intended to be comprehensive, but 

merely a starter for individuals using ArcMap software. For basic analysis of things such as 

distance; nearest neighbor; measures of geographic distribution such as geographic mean and 

median, Standard distance, and directional distribution; and point density there are several tools 

that will be helpful. 

 

                                                 
11 http://desktop.arcgis.com/en/arcmap/10.4/manage-data/geocoding/creating-an-address-locator.htm 

 

http://desktop.arcgis.com/en/arcmap/10.4/manage-data/geocoding/creating-an-address-locator.htm


Distance between two points can be calculated as Euclidean distance (i.e. as the crow flies) or 

along a route (i.e. as someone would drive). For route distance see the section on Network 

Analyst Tools. Euclidean distance can be calculated for any inputs to either a single feature or 

several features. The Point Distance tool (ArcToolbox > Analysis Tools > Proximity > Point 

Distance) calculates the straight-line distance between two features and can be used for multiple 

inputs. When calculated, the distance is recorded in the attribute table of the input feature. 

 

Nearest neighbor tools may be useful when trying to determine which hospital, grocery store, 

school, or other point of interest is nearest to an input point. The Near Tool (ArcToolbox > 

Analysis Tools > Proximity > Near) will calculate the straight-line distance between input 

features and the nearest feature in another layer of interest. When calculated, the distance and 

the identity of the nearest feature are recorded in the attribute table of the input feature. 

 

For measures of geographic distribution, the Spatial Statistics Toolbox will be helpful. The tools 

here (ArcToolbox > Spatial Statistics Tools > Measuring Geographic Distributions > Mean 

Center, Median Center, Standard Distance, Directional Distribution) will allow determination of 

the geographic mean center and the median center (the average location and median location of 

where the points on a map are located), See A below. Standard Distance replaces standard 

deviation for points on a map and can be used to determine the distribution of points around the 

center with 68% of points being contained within one standard distance of the center, see B 

below. If the points are not normally distributed around the center a Directional Distribution tool 

may be more applicable and will give standard distance ellipses that contain directional 

information as well, see C below. 

 

                 

 

 

 

 

 

 

 

 

 

A: Example of Geographic Mean Output; the 

output point is not a point existing in the input 

layer 

B: Example of Standard Distance output, contains 

roughly 68% of points when normally distributed 

around the center. 

C: Example of Directional Distribution ellipse 

output, contains about 68% of points and preserves 

directional information 



 

 

Point Density (ArcToolbox > Spatial Analyst Tools > Density > Point Density) can be a very 

useful tool for visualizing ‘hot spots’ in the data.  By dividing the number of points in a cell of 

defined area, a density value can be calculated and represented on the map, see D below.  

 

For further information on different tools and 

functions in ArcMap please refer to the software 

help guide by right-clicking any tool and selecting 

“Help” or refer to online support with ArcMap’s 

“Tool Reference”.12 

 

 

 

 

 

 

Building a Network Dataset: 

The tools discussed above are useful for many things, however when trying to analyze more 

complex interactions between feature points, a Network Dataset can be helpful. For features 

connected by a network such as streets or transit networks, the Network Dataset stores the 

connections within the network(e.g. which streets are connected to each other, what transit routes 

are connected, what rivers are connected, etc…) and allows the software to analyze different 

routes and paths through the network to solve problems and further analyze features.  A Network 

Dataset is created from source data and stores the connectivity of the source data, as well as a 

variety of other information such as traffic information, speed, tolls, etc. which can be used for 

various analyses and problem solving with Network Analyst Tools (see next section). 

 

Building a Network Dataset or having a Network Dataset are prerequisites for using Network 

Analyst tools. The complexity of the Network Dataset is dependent on the requirements of the 

questions being asked. What are the driving directions, what is the shortest/longest route, and 

similar questions would only need simple networks to answer, however adding in public transit 

with its different timetables, ability to walk between stops, and multiple connections between 

different modalities (Bus, trolley, train, bike paths, etc…) adds increasing complexity and 

increasing skill to build such a network. What follows is a simple guide to building a Network 

Dataset from available road data, to answer simple route questions, many of which will be 

covered in the following Network Analyst Tools section.  

 

To begin, collect the reference data that will be used to construct the dataset, often shapefiles, 

and ensure that the data contains information pertinent to the questions asked. For example, 

trying to evaluate travel time along a route requires knowing the speed limit and distance of the 

route. While shapefiles might have distance and speed limit data, they may not contain travel 

time data and will need to have this calculated. This can be done by adding a field to the 

shapefile attribute table and calculating the required data by dividing the distance values by 

speed values ( be certain to pay attention to the units used). 

                                                 
12 http://desktop.arcgis.com/en/arcmap/10.4/tools/main/a-quick-tour-of-geoprocessing-tool-references.htm  

D: Example of Point Density Function with 

multiple inputs 

http://desktop.arcgis.com/en/arcmap/10.4/tools/main/a-quick-tour-of-geoprocessing-tool-references.htm


 

With the reference data properly prepared, open the “Catalog” window and navigate to the 

reference data to be used; right click on the reference data and select “New Network Dataset”. If 

unavailable, ensure that Network Analyst is enabled under Customize > Extensions > Network 

Analyst.  Multiple reference files can be used to construct the Network Dataset, please refer to 

the Network Analyst Tutorial published by ESRI for more information.13 Selecting New 

Network Dataset will launch a creation Wizard to guide the process. See Appendix G for further 

information with an example. 

 

If a previously created Network Dataset is available, this can always be loaded into the map 

same as other data files and can be used for Network Analyst Tools right away. 

 

Network Analyst Tools: 

The Network Analyst Toolset is used for analyzing a network and offers solutions to several 

different types of problems. They are well suited for analyses involving a transportation network. 

The main problem-solving tools are Route, Closest Facility, Service Layer, and Location-

Allocation. 

 

A Route Layer (ArcToolbox > Network Analyst Tools > Analysis > Make Route Layer) helps 

determine the best route between network locations dependent on specific ‘costs’ in the network. 

Costs are classically some kind of impedance to use such as time or distance (i.e., the route layer 

can be set up to solve for shortest route, shortest time, etc…). Selecting the Make Route Layer 

tool will open a wizard requesting information on what Network Dataset to use, and what ‘costs’ 

to evaluate. Once completed this will place an empty route layer into the map’s table of contents. 

To create a route, ‘stops’ will need to be added to the route; use the Add Locations tool in this 

toolbox, or use the Network Analyst window to add ‘stops’. Once the stops are added, the Route 

Layer can be solved, and if successful will provide route information in the attribute tables.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                                                 
13 http://help.arcgis.com/en/arcgisdesktop/10.0/pdf/network-analyst-tutorial.pdf  

Example of Route Analysis between Hillcrest and UCSD Campus; the route chosen 

minimizes the drive time 

http://help.arcgis.com/en/arcgisdesktop/10.0/pdf/network-analyst-tutorial.pdf


A Closest Facility Analysis (ArcToolbox > Network Analyst Tools > Analysis > Make Closest 

Facility Layer) is designed to find the closest facility to a specified starting point. Similar to the 

Route Layer, selecting this tool opens a wizard to select parameters. In this analysis, add the 

incident locations to be used, as well as all the potential facilities to be evaluated for the closest. 

The analysis can be set to solve using several different costs such as distance or time. Once 

solved, the attribute table will contain the closest facility pairings and route information.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A Service Area Layer (ArcToolbox > Network Analyst Tools > Analysis > Make Service Area 

Layer) is useful for determining the accessibility of areas given a cutoff cost from a facility. This 

type of tool is commonly used in setting service areas for things like fire and police departments; 

this defines the areas that can be reached from the station in x-minute or x-distance cutoffs, or 

other cost units. To create a Service Layer, load the locations and indicate the impedance costs to 

be used as well as how many cutoffs to create (e.g. 1 minute, 5 minutes, 10 minutes, etc…). 

When solved, the Service Layer will display a series of polygons around the facilities 

representing the area that is accessible within the cutoff. 

 

 

 

 

 

 

 

 

 

 

Example of Service Areas generated around two points with 3, 6, 9 and minute polygons 

Example of a Closest Facility Analysis; an incident location is represented by the 

square, and the closest facility by distance is represented by the route in blue 



 

 

 

 

 

 

 

A Location-Allocation Layer (ArcToolbox > Network Analyst Tools > Analysis > Make 

Location-Allocation Layer) is useful for picking several facilities from candidate facilities so that 

demand for facilities is optimally distributed. For the analysis performed by the Free Clinic, this 

was used to determine an optimal location for a new clinic; several thousand grid squares were 

analyzed against where Free Clinic patients live to come up with an ideal location. There are 

many more uses for this kind of analysis, and there are several problem types that can be used to 

alter the analysis such as “Minimize Impedance,” “Maximize Coverage,” “Maximize 

Attendance,” etc.  For more information on these problem types please refer to ArcGIS Desktop 

Tools.14 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Summary: 

Spatial Analyses are a vital part of evaluating patient care. Despite the availability of resources 

for performing such analyses, they continue to remain an underutilized aspect of clinical care. 

For the Free Clinic, and many others who care for marginalized populations, spatial analysis is 

an easily repeatable, and adaptable tool for improving care. Using these tools, the Free Clinic 

was able to determine a new location to move a clinic of more than 235 regular patients.  As 

well, the analysis highlighted an opportunity to reassign patients to different clinic sites to reduce 

travel times and issues of access, which has become an ongoing project at the Free Clinic with 

implementation of trials of patient transfers between clinics.  

 

                                                 
14 http://desktop.arcgis.com/en/arcmap/10.4/tools/network-analyst-toolbox/make-location-allocation-layer.htm  

Example of a Location Allocation Analysis; several candidate squares are shown, by 

minimizing travel time from the two circles, a single candidate square is identified with a 

star 

http://desktop.arcgis.com/en/arcmap/10.4/tools/network-analyst-toolbox/make-location-allocation-layer.htm


Given the wide adaptability of spatial analyses there are several different future directions for 

this work. One great area to apply this work is in health profiling; public health applications have 

made great strides in this use of GIS, and this has far reaching implications for clinicians. On a 

smaller scale this can be applied to create profiles of Free Clinic populations to help describe the 

relationships between health and setting; for example, profiles could be developed examining 

diabetes or blood pressure control based on where patients live which might help target clinic 

efforts. A second application involves the allocation of resources. Patients at the Free Clinic 

receive a variety of care from primary to specialty medical services as well as, dental, legal, 

social work, nutritional and other care. The resources required for these services are not equally 

distributed and future applications may desire to quantify where the need for these services is 

located, and how best to distribute limited resources to match. Further applications abound in the 

realm of questions regarding how place affects health and applies broadly to health and patient 

care from the neighborhoods where patients live to national and even global levels. 

The rise of “big data” and informatics are transforming lives. In contrast, the rise of health-

related GIS applications has been slower, however its potential is tremendous. It is imperative 

then that the healthcare providers be knowledgeable in GIS techniques and uses as this will 

likely be pivotal in transforming patient care into the future. While by no means definitive, 

hopefully this guide can be leveraged as a resource for those students interested in the 

applications of GIS and improving patient care. 



  

Appendix 

 
 

Appendix A: Shapefiles 

 

Most Shapefiles are downloadable as a Zip file which contains all the subfiles necessary to use 

the shapefile. If one of the subfiles is missing or damaged the entire shapefile may not work. On 

the left is a Zip file containing all the subfiles in a shapefile. When accessed in ArcGIS, these 

files will appear as in the picture on the right. 

 

Appendix B: Adding Data/Shapefiles 

 

When a new ArcMap is opened there is a blank screen that you can add layers onto to begin. In 

the toolbar at the top, select add data. This will open a file browser where you can connect to 

files stored on the PC, or on a separate drive like a flash drive. Use this file browser to locate the 

shapefiles you would like to add as layers. You may need to “connect to a folder” to find the files 

you want to add. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                                                                                         

 

 



 

Appendix C: Adding Excel data into ArcMap 

 

Adding a table of data into ArcMap can be done in several ways. A simple way is to use the Add 

Data function that was discussed in Appendix B. Excel sheets can be added directly into 

ArcMap, but keep data organized under simple headings to prevent syntax errors when uploading 

an Excel sheet. Of note, .xlsx files may not be recognized by the software and may need to be 

converted to .xls format. For this example, we have an Excel table with two University addresses 

representing Hillcrest Hospital (200 W. Arbor Dr.) and the UCSD campus (9500 Gilman Dr.). 

 

 

 

 

 

 

 

Click Add Data and navigate to the Excel document and specific sheet that you would like to 

add.  The sheet will appear in your data layers.  

 

 

 

 

 

 

 

 

 

 

 

Right click on the sheet you added and select “Open,” which will open the datasheet you just 

added at the bottom of the window. You can see that you have successfully imported your data 

into ArcMap. 

 
 

 

 



  



Appendix D: Resolution and GIS data security 

 

Resolution is the big concern when it comes to protecting patient and other health care data. Its 

relatively harmless to provide information about how many patients might live in each zip code 

as that provides relative anonymity, but to provide street address level data about where patients 

live makes it much easier to identify those patients. Therefore, it is important that steps be taken 

to control who has access to the maps created, and the data they obtain. There are several ways to 

mask or “jitter” data to make it more difficult to identify individuals and these are widely 

accepted methods in a variety of geomapping applications.15  Heat maps can be a great way to 

visually mask where individuals live, but allow a density or clustering effect to still be apparent, 

just be aware if sharing/publishing maps in certain software formats that the underlying data to 

create the heat map is often still attached and could be accessed to extract individual addresses 

and locations. Exporting maps as .pdf, or other image formats should alleviate this risk. 

 

  

                                                 
15 Paul A. Zandbergen, “Ensuring Confidentiality of Geocoded Health Data: Assessing Geographic Masking 

Strategies for Individual-Level Data,” Advances in Medicine, vol. 2014, Article ID 567049, 14 pages, 2014. 

doi:10.1155/2014/567049 



Appendix E: Building an Address Locator 

 

Access the Create Address Locator tool at Geoprocessing > ArcToolbox > Geocoding Tools > 

Create Address Locator. This will open the tool as seen below. Select the type of address locator 

you would like to use such as single or dual range, streetname, zipcode, state, etc…  With the 

type selected, load the reference data you will use, see A below. In this example the data is street 

information provided from a SanGIS shapefile; other sources could be based on census tract 

information, zipcode, or city/state files.  With the reference data loaded, the address locator will 

need to have certain fields associated with the fields of the reference data; select the 

corresponding headers as shown in B. Chose a location to save the Address Locator (output) and 

click ok to generate the locator. If successful, the locator can be used to geocode addresses and 

locations. 

 

A.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

B.   

The field names required 

are marked with an asterisk. 

They need to be associated 

with an alias name that 

exists in the reference data. 

The more associations 

provided the more accurate 

the Address Locator, but 

not every field is necessary 

depending on the 

application. 



Appendix F: Geocoding Addresses 

 

This can be done with an Excel Sheet uploaded into ArcMap already or available on the 

computer. Open the Geoprocessing Toolbar > ArcToolbox > Geocoding Tools > Geocode 

Addresses.  

 

 

 

 

 

 

 

 

 

 

 

 

 

This will open the Geocode Addresses Dialog box, which is filled out with an example below. 

The example is using the Address Example.xls table containing UCSD’s main campus address, 

and Hillcrest Hospital’s address, and using an Address Locator to geocode these addresses. 

 

 

Selecting OK in the dialog box will run the geocoding process and will automatically output a 

shapefile of the addresses that were geocoded.  

 

 

 

 

 

 

 



Addresses that fail to geocode will still be in the data table but will not be displayed on the map; 

it is possible to go in and edit the addresses in the data table for things like spelling errors, or 

incorrect zip codes and try to re-geocode them. In this example there is a base layer map of La 

Jolla, and you can see the two green dots overlaid on the map representing the addresses we 

wanted to geocode (UCSD, and Hillcrest Hospital). 

 

 
 



Appendix G: Building a Network Dataset Example: 

 

For this example, a shapefile containing all roads in San Diego (All_Roads.shp, available from 

SanGIS) is used. Drive time data is not available in the reference data, and therefore calculations 

of drive time will be difficult in the final dataset. To correct this the drive time in minutes was 

calculated for each road segment by dividing the [distance] / [speed].  

 

With the Roads_All shapefile loaded, right-click 

and open the Attribute Table to edit the fields. 

 

Name the new field and set the 

value, usually “Double.” In this 

example it was named Minutes. 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

The value of the field defaults to 0, and must be 

calculated or provided. Right-click on the Minutes 

header and select “Field Calculator”. This will 

open a syntax calculator (see right); the correct 

syntax must be written to get the values desired for 

drive time in minutes. For drive time divide 

[distance] / [speed], ensure the units are correct. In 

this case distance is in feet, speed is miles per hour, 

and drive time is desired in minutes therefore the 

syntax is “5280/[distance]*60/[speed]”. Select OK, 

and all fields will be calculated with the drive time 

for that segment in minutes.  

 



With the Minutes field calculated to represent drive time, save the data as a shapefile by right-

clicking the file in the table of contents, Data > Export Data. The newly saved shapefile is now 

ready to create a Network Dataset.  

 

Open the Catalog window, found under the Windows tab, and locate the shapefile being used as 

reference data. Right-click and select “New Network Dataset”. 

 

 

  

 

 

 

 

 

 

 

 

This will open the New Network Dataset Wizard, which will guide users through the process. 

Begin with naming the new Network Dataset. Select “Yes” for model turns in network.  

 

  

 

 

 

 

 

 

Connectivity, i.e., where do all of the lines connect in this network, can be changed by selecting 

the connectivity button, however the default settings are typically sufficient. 

 

 

 

 

 

 

 

 

 

 

 

 

Elevation should be determined in the network to ensure that proper connections are made, for 

example freeway overpasses look like they intersect with the lower roadway on a map, however 

in reality there is no connection between the two and this must be modeled. If the reference data 

contains elevation fields, these should be used to model elevation in the network. Select the 

“Using Elevation Fields” button and associate the “From End” elevation with the corresponding 



field in the reference data, repeat for the “To End”.  Reference the source data regarding 

elevation data, and which fields correspond to the associations needed. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The next page of the wizard allows for attributes of the network to be set; the software is able to 

recognize these fields in the data and will often attempt to self-populate, but additional attributes 

can be added and used. These attributes are important as they are used for calculating solutions 

to Network Analyst problems. If solving for the shortest route, or the fastest route it is important 

to have time and distance attributes specified and how they will be calculated. Use the Add 

button to Add new attributes, and Evaluators to change how the attributes are calculated.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



After specifying the necessary attributes, specify the travel mode for the network. This is useful 

when trying to model different modes of traveling the network. For example, cars are bound to 

follow one-way restricted roads, but a pedestrian is not required to follow such restrictions, and 

therefore changes the way that the network might be travelled. Travel modes can be added and 

removed, and basic modes like car or pedestrian are already modelled.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Following this, the wizard will ask to establish driving directions. This can be done as needed for 

the analysis being performed. Simply associate the “Name” field with the reference data field 

containing name data.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

Following the directions, the wizard will display a summary page. Click “Finish” when done and 

the wizard will prompt with an option to build the Network Dataset and then add its parts to the 

map. Once this is completed successfully, the Network Dataset is available to used with Network 

Analyst Tools.  




