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CSISS - GIS Cookbook: Introduction & Table of Contents

GIS Cookbook: Introduction

The GIS Cookbook is a collection of simple descriptions and illustrations of GIS methods written with 
 minimal GIS jargon. Recipes cover two GIS software platforms, ArcView 3.x and ArcGIS 8/9.x. The 
 target users are social scientists with an interest in introducing spatial thinking into their current research 
and also having some experience with computers but little to no exposure to GIS. The GIS Cookbook 
was prepared in 2002-2005 to serve the expanding community of social scientists wanting to apply GIS 
for research and teaching.

GIS Cookbook Table of Contents
ArcView

3.x
ArcGIS

8.x
ArcGIS

9.x

1. Getting Started

How to Open a Map Document, then Add Data 3.x 8.x 9.x

How to add data after opening a new view 3.x

Performing an Attribute Query 8.x 9.x

Performing a Spatial Query 8.x 9.x

2. Dealing with Data

Importing an Excel table to your GIS project 3.x 8.x 9.x

Joining a table to an existing table 3.x 8.x 9.x

Classifying data 3.x

3. Classifying and Visualizing Data

Making a choropleth map 3.x 8.x 9.x

4. Projections

Define projection for a shapefile or geodatabase 8.x 9.x

Reprojecting data 3.x

5. Datums

Recipes in progress

6. Buffers

Buffering an area 3.x 8.x 9.x

http://csiss.org/
http://spatial.ucsb.edu/
http://spatial.ucsb.edu/
http://gispopsci.org/
http://gispopsci.org/
http://teachspatial.org/
http://teachspatial.org/
http://csiss.org/aboutus/programs.php
http://csiss.org/aboutus/programs.php
http://csiss.org/learning_resources/
http://csiss.org/learning_resources/
http://csiss.org/resources/
http://csiss.org/resources/
http://csiss.org/clearinghouse/
http://csiss.org/clearinghouse/
http://csiss.org/search/
http://csiss.org/search/
http://csiss.org/events/
http://csiss.org/events/
http://csiss.org/resources/litsearch.php
http://csiss.org/resources/litsearch.php
http://csiss.org/aboutus/
http://csiss.org/aboutus/


CSISS - GIS Cookbook: Introduction & Table of Contents

7. Geocoding

How to geocode addresses 3.x 8.x

Selecting from geocoded addresses 3.x

8. Census Data

Recipes in progress

9. Density Estimation

Recipes in progress

10. Cartographic Design

Preparing your map for presentation without a template 3.x 8.x

Shortcut to preparing your map for presentation with a template 3.x 8.x

Creating a report 3.x

Adding and editing a legend 3.x 8.x

Adding a scale bar to a Layout 3.x 8.x

Adding a neatline or border to a layout 3.x 8.x

Automatically labeling a map 3.x

Adding individual labels to your map 3.x

Adding a north arrow to your map layout 3.x 8.x

Adding text or a title to a layout 3.x 8.x

Appendix

A. Background Information about Geocoding

B. Background Information about Buffers

C. Background Presentations and Finishing

Glossary

http://csiss.org/aboutus/programs.htm
http://csiss.org/learning_resources/index.html
http://csiss.org/resources/index.htm
http://csiss.org/clearinghouse/index.php3
http://csiss.org/search/index.htm
http://csiss.org/events/index.htm
http://csiss.org/membership/vccenter.htm
http://csiss.org/aboutus/index.htm
http://csiss.org/sitemap.html
http://csiss.org/aboutus/contact.htm
http://csiss.org/plugins/index.htm
http://csiss.org/aboutus/privacy.html
http://csiss.org/aboutus/credits.htm
http://csiss.org/
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 GIS Cookbook: Getting Started - How to Open a New Project, New View, or
 Existing Project, then Add Data 

Keywords: New View, ArcView, project, open project
Category: Starters
Software: ArcView 3.2

Problem: Most recipes require me to open a new view or project and then add data. How do I do these 
 tasks?

Description: At the start of many recipes, the first line of instruction will be to "open a new view." The  
following recipe will show you how to execute this step. 

Methodology:
1) Click on the Start button, go to Programs, go to ESRI, select ArcView 3.2. The following windows will
appear on your screen. If you are not able to find the program this way, See Pitfall 1.
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2a) To open a New Project with a New View, select the bullet next to "with a new view" and then select  
OK. 

2b) To open an existing project, select the "open existing project" bullet. Then select OK.
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3) After selecting OK to opening a New View, the program will ask if you would like to add data. The
following window will appear on your screen.

 To add data, select Yes. The following window will appear, with which you can navigate to upload the data
 files you would like to add to your view. 
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4) After selecting the data file, select OK.
Pitfalls:

If you cannot find ArcView within your Start Menu, go to Start and search for the application using
 the Find tool. Your programs will be in different locations depending on where they were placed
 during program installation.

Authored by: Sam Ying Modified: 9/11/03

Copyright © 2002-2015 by Regents of University of California, Santa Barbara
 Cookbook: Ben Sprague, Ethan Sundilson, Carlin Wong, Sam Ying
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 GIS Cookbook: Getting Started - How to Open a Map Document, then Add Data 

Keywords: ArcMap, project, open project, add data, map document, open map document
Category: Starters
Software: ArcGIS 8/9.x

Problem: Most recipes require me to open a new map document (project) and then add data. How do I do these tasks?

Description: At the start of many recipes included in the CSISS Cookbook, the first lines of instruction will be to "open a new map document" and then to "add data."
 The following recipe will show you how to execute these steps. 

Methodology:
1) Click on the Start button, go to Programs, go to ArcGIS, select ArcMap. The following windows will appear on your screen. If you are not able to find the program
this way, please See Pitfall 1.

2a) To open a new map document with an empty data frame, select the bullet next to A new empty map and then select OK. 
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Starting a new map document

2b) To open an existing project, select the An existing map bullet. Then select OK.
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Open an already existing map document

3) After selecting a map document, you can now add data.
To add data, click the Add Data Button.
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Note: You can also go to File -> Add Data .
 The following window will appear
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Adding data

4) First, you will map your data drive. This allows you to select the directory and folder within which your data layers are stored, so you do not have to search for the
folder every time you upload data. This way, you only need to direct the program to that folder once.



CSISS - GIS Cookbook: Getting Started - How to Open a Map Document, then Add Data

 Click on the Connect to Folder button in the Add Data window. 

 The Connect to Folder window will appear. Use it to navigate to the folder where the data files you would like to add to your map are located. 
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Connect to the folder where your data is located

5) After connecting to the folder, navigate to the data file or files you would like to add and select the data files by clicking on them (use the Shift or Ctrl keys to select
multiple files), and then click Add.
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6) Your data will appear in your map window. You can repeat the Add Data process as many times as necessary. However, once you have connected to your folder
one time you do not have to do it again, unless you would like to retrieve data from another folder or directory.

Pitfalls:
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If you cannot find ArcMap within your Start Menu, go to Start and search for the application using the Find tool. At the find prompt (it will look different
 depending on your operating system), type "Arcmap.exe" without the quotes. Your programs will be in different locations depending on where they were
 placed during program installation.

Authored by: Benjamin N. Sprague Modified: 2/4/05

Copyright © 2002-2015 by Regents of University of California, Santa Barbara
 Cookbook: Ben Sprague, Ethan Sundilson, Carlin Wong, Sam Ying
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 GIS Cookbook: Getting Started - How to Add Data after Opening a New View 

Keywords: Add data, new view, existing data
Category: Starters
Software: ArcView 3.2

Problem: How do I add data to my view or my project?

Description: After opening a new View or existing data, you will often need to add data to your view.
 The following recipe will show you how to execute this step. To see how to open a new View or existing
 project, refer to recipe How to open ArcView and a New View or Existing Project.

Methodology:
1) To open a new view in an existing project select the Views icon

 within the project manager window, then select New.

http://csiss.ncgia.ucsb.edu/cookbook/starter/12
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2) To add data, select the Add Data button

 The Add Data button can be found near the top of the ArcView 3.x window next to the Save button
 marked as a floppy disk icon. This will lead you to a directory where you can navigate to your data files
 to be uploaded onto the view. 

3) After you have selected the title of the file on the directory, select OK.

Authored by: Sam Ying Modified: 9/9/03

Copyright © 2002-2015 by Regents of University of California, Santa Barbara
 Cookbook: Ben Sprague, Ethan Sundilson, Carlin Wong, Sam Ying
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 GIS Cookbook: Getting Started - Performing an Attribute Query 

Keywords: query, attribute, select, tabular, SQL
Category: Starters
Software: ArcGIS 8/9.x

Problem: You want to select map features that have certain tabular attributes.

Description: One of the most common functions in a GIS is the ability to ask the software to display all
 of the geographic features that meet some criteria. These criteria may be based on information stored
 in a layer’s attribute table (an attribute query) or they may involve desired spatial relationships between
 features in different geographic data layers (a spatial query). This recipe will focus on building an
 attribute query.

Methodology:
 Assuming you have ArcMap open and have added all of the desired data layers, you can build an
 attribute query as follows:

1. Click on Selection > Select By Attributes.

2. In the Select By Attributes dialog, be sure to select the Layer whose attribute table you’d like to
query. Upon selecting a layer, you should see a list of its Fields (or columns) appear on the left side of
the dialog.

3. In the Fields list, double-click on the desired field. Note that the name of the field is added to the
large text box in the bottom half of the window.

4. Next, click on one of the logical operators in the middle of the dialog (such as =, >, ≥, etc.).

5. The last step in building the query expression is to enter a value that is appropriate for the field and
that defines your selection criteria when combined with the chosen logical operator. You may place the
cursor at the end of the expression and manually type the desired value, or you may click the Get
Unique Values button to see a list of the unique values within the chosen field and then double-click
on one of the values listed to insert it at the end of the expression.

6. When you’ve finished building the query expression, click the Apply button. ArcMap will highlight the
features that meet your criteria in the selection color (cyan, by default).

See Pitfall 1
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Using the Select By Attributes dialog to select U.S. states with a population density greater than 75.

 Notes:
1. One of the options in the Select By Attributes dialog is Method. This defaults to Create a new
selection, which means that if there are already some features selected, that selection set will be
wiped out. Other choices include: Add to current selection, Remove from current selection, and
Select from current selection. These other selection methods may be used to evaluate multiple
attribute criteria one at a time.

2. Another way to evaluate multiple selection criteria is to use the logical operators And and Or. For
example, if you wanted to select states with a population density over 75 and at least 50000 farms,
after entering the value 75 you could click the And operator, then begin the three-step process (field-

operator-value) again to enter the second part of the compound expression.

3. If you open the layer’s attribute table, note that the tabular records associated with the selected map
features are also shown in the selection color. In fact, it is possible to invoke this same Select By
Attibutes dialog by clicking on the Options button in the lower right of an open attribute table window.

4. Besides simply seeing which map features meet some criteria, creating a selection set is an
important step in performing a number of other GIS functions. These include:

Using the selection set for further analysis (such as buffering the selected features)

Using the selection set to select features in another layer

Editing the selection set (either the geometries of the features or their attributes)

Creating a new layer from the subset

Calculating summary statistics for the selected features
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and more...

5. Using the Save and Load buttons in the Select By Attributes dialog, it is possible to store query
expressions on disk and re-load them at a later time.

Pitfalls:

New users frequently encounter syntax errors when using the Select By Attributes dialog.
 Remember to double-click on the items in the Fields and Unique Values list boxes and single-
click on the logical operator buttons. If you're unable to pinpoint the error in your expression, it
 may be easiest to click the Clear button and start again.

Authored by: Jim Detwiler Modified: 3/6/05

Copyright © 2002-2015 by Regents of University of California, Santa Barbara
 Cookbook: Ben Sprague, Ethan Sundilson, Carlin Wong, Sam Ying
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 GIS Cookbook: Getting Started - Performing a Spatial Query 

Keywords: query, spatial, topological, select by location
Category: Starters
Software: ArcGIS 8/9.x

Problem: You want to select map features based on their spatial relationship with other map features.

Description: One capability that distinguishes GIS software from simple drawing packages is the ability
 to explore the spatial relationships between map features in different layers. These relationships (often
 referred to as topological relationships after the branch of geometry called topology) include
 connectivity, adjacency, and containment. GIS software enables researchers to ask questions like:

Which roads are connected to Interstate 80?

Which census tracts are adjacent to this industrial park?

How far is the nearest bus stop from each of my study subjects?

Which schools are contained within this Metropolitan Statistical Area?

Etc.

Methodology:
 Many of these types of questions can be answered by building a spatial query using the Select By
 Location dialog. Assuming you have ArcMap open and have added all of the desired data layers, you
 can build a spatial query as follows:

1. Click on Selection > Select By Location.

 Setting the options in the Select By Location dialog can be approached by constructing a sentence that
 describes the query, beginning at the top with the words, I want to:. 

2. The first option is the selection method. In most instances, the default option of select features from
is the most appropriate. See Note #1 for more information on selection methods.

3. The next step is to specify which layer(s) contain the features you’d like to select by choosing from
the list under the words the following layer(s).

4. Next comes the choice of an appropriate spatial relationship from the drop-down list under the word
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 that:. See Figure 1 for a list of available relationships.

Spatial relationships available in the Select By Location dialog

5. To complete the sentence, you must choose the other layer participating in the relationship by
selecting from the list under the words the features in this layer:.

6. Click Apply to execute the query. Figure 2 shows an example of a point-in-polygon selection.
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Selecting CITIES features that intersect features in the Western States layer

7. Optionally, you may want to specify that only the selected features in the query layer (Western
States in this example) be used to find matching features in the target layer. This can be done by
clicking the Use selected features checkbox as shown in Figure 3.
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Selecting CITIES features that intersect just the selected features in the Western States layer

8. Buffering the features in the query layer is another optional setting. When the are within a distance
of relationship is selected, this checkbox is automatically checked. Upon selecting this option, the next
step is to enter the desired buffer distance. Figure 4 shows an example of selecting cities within 100
miles of the Nevada border.
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Selecting CITIES features within a distance of 100 miles from the selected Western States features

 Notes:
1. The first drop-down list in the Select By Location dialog provides a list of selection methods. It
defaults to Select features from, which means that if there are already some features selected, that
selection set will be wiped out. Other choices include: Add to the currently selected features in,
Remove from the currently selected features in, and Select from the currently selected features
in. These other selection methods may be used to evaluate multiple spatial queries one at a time.

2. If you open the layer’s attribute table, note that the tabular records associated with the selected map
features are also shown in the selection color.

3. Besides simply seeing which map features meet some criteria, creating a selection set is an
important step in performing a number of other GIS functions. These include:

Using the selection set for further analysis (such as buffering the selected features)

Using the selection set to select features in another layer

Editing the selection set (either the geometries of the features or their attributes)

Creating a new layer from the subset

Calculating summary statistics for the selected features

and more...
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Authored by: Jim Detwiler Modified: 3/6/05

Copyright © 2002-2015 by Regents of University of California, Santa Barbara
 Cookbook: Ben Sprague, Ethan Sundilson, Carlin Wong, Sam Ying
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 GIS Cookbook: Recipe - Importing an Excel table to your GIS project 

Keywords: Tables, Excel, linking, joining, data management
Category: Data Analysis
Software: ArcView 3.2

Problem: I have data in an Excel format, how do I use it within my ArcView project?

Description: Often the data we work with does not come nicely packaged in a GIS data file. Instead we work with
 a variety of different data sources. In this recipe we will convert data from an Excel database into GIS friendly
 formats and then import them so that they can be used within your ArcView project.

Methodology:
1) Open Excel, and the data file that you want to use in ArcView. Bring up the exact data spreadsheet you would
like to import.

2) Go to the File -> Save As menu option

3) Set the Save in: folder to a familiar directory and remember where you saved it.

4)Set the Save as type: to DBASE IV.
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the Save As window

5) Set your file name appropriately and click Save.

6) A message while appear about multiple worksheets, Click OK to the verification message about multiple
worksheets. (Note: If you have multiple work sheets in your excel workbook, you will need to repeat steps 1-6 for
each that you would like to import to ArcView)

7) Then Click Yes to the informational message regarding formats. The Data you selected is then written to disk as
a DBase file.

8) Close excel.

9) Open ArcView 3.x. You can either import it to a new project, or to a existing project.

10) Use the Add Data button to add the DBase files to the map. If you do not know how to do this yet see the recipe
How to Open a New Project and View or Existing Project, then Add Data (ArcView 3.2).

11) Navigate to the folder where you saved the .dbf files. Select the file or files you would like to add, and click the
Add button. If you receive an error message See Pitfall 1, or See Pitfall 2.

12) The DBase tables are displayed in your view.
Pitfalls:
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If your error message says that the file is busy or already in use, it means that you have left the .dbf file you
 are trying to import open in excel. Makes sure the file you are importing and preferably excel are closed
 before you import the data. Link
If your error message says that the format is not accepted or ArcMap cannot read the format, there is an
 error either with your file type (eg. wrong format) or there is an error within your data that prevents it from
 being imported (this may include extra spaces within columns, empty cells, and many other consistancy
 issues) Try to make your data as neat as possible and try again.

Authored by: Benjamin N. Sprague Modified: 9/9/03

Copyright © 2002-2015 by Regents of University of California, Santa Barbara
 Cookbook: Ben Sprague, Ethan Sundilson, Carlin Wong, Sam Ying
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 GIS Cookbook: Recipe - Importing an Excel table to your GIS project 

Keywords: Tables, Excel, linking, joining, data management
Category: Data Analysis
Software: ArcGIS 8/9.x

Problem: I have data in Excel format, how do I use it within my ArcGIS project?

Description: Often the data we work with does not come nicely packaged in a GIS data file. Instead we work with
 a variety of different data sources. In this recipe we will convert data from an Excel spreadsheet into a GIS-friendly
 format and then import them so that they can be used within your ArcMap map document.

Methodology:
1) Open Excel to the data file that you want to use in ArcMap. Bring up the exact data spreadsheet you would like
to import.

2) Go to the File -> Save As menu option

3) Set the Save in: folder to a familiar directory and remember where you saved it.

4)Set the Save as type: to DBASE IV.
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The Save As window

5) Set your file name appropriately and click Save.

6) A message will appear about multiple worksheets. If your data are in a worksheet other than Sheet1, be sure to
select that sheet here. Otherwise, just accept the default Sheet1. (Note: If you have multiple worksheets in your
Excel workbook, you will need to repeat steps 1-6 for each that you would like to import to ArcMap.)

7) Then Click Yes to the message regarding formats. The Data you selected is then written to disk as a dBase file.

8) Close Excel.

9) Open ArcMap. You can either import it to a new map document, or to a existing map document.

10) Use the Add Data button to add the dBase files to the map. If you do not know how to do this yet see the
recipe How to Open a Map Document, then Add Data (ArcGIS 8.x/9.x).

11) Navigate to the folder where you saved the .dbf files. Select the file or files you would like to add, and click the
Add Data button. If you receive an error message See Pitfall 1, or See Pitfall 2.

12) The DBase tables are displayed in your active data frame.
Pitfalls:

If your error message says that the file is busy or already in use, it means that you have left the .dbf file you
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 are trying to import open in Excel. Make sure the file you are importing and preferably Excel are closed
 before you import the data.
If your error message says that the format is not accepted or ArcMap cannot read the format, there is an
 error either with your file type (e.g., wrong format) or there is an error within your data that prevents it from
 being imported (this may include extra spaces within columns, empty cells, and many other consistency
 issues) Try to make your data as neat as possible and try again.

Authored by: Benjamin N. Sprague Modified: 2/4/05

Copyright © 2002-2015 by Regents of University of California, Santa Barbara
 Cookbook: Ben Sprague, Ethan Sundilson, Carlin Wong, Sam Ying
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 GIS Cookbook: Recipe - Joining a table 

Keywords: Data, joining, relates, sorting, data analysis
Category: Data Analysis
Software: ArcView 3.2

Problem: I have information in a table that I would like to join to a point, polygon or line feature.

Description: Often times, the information you want to display or analyse within GIS is in two different places
 or formats. Often you will have a map of a standard area, like the counties in a state or the states of a
 country, and you will want to add external data to them so you can look at your data in a spatial context. In
 this recipe we will look at how to join data to a shapefile. 

Scenario:
 Ever since the work of John Snow and his mapping of Cholera cases, mapping cases and frequencies of
 diseases can help to find sources and cures. One of the major research topics of the 20th century is the
 search for an understanding of cancer. It helps researchers in the subject to know where the cases of
 cancer are the highest. In this scenerio, we are going to look at the state of New Mexico and join the the
 cancer statistics for each county to the counties within the state.

Methodology:
1) Open ArcView

2) Add the shapefile you wish to attach your data too.
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Your starting theme

3) Click on the shapefile in the table of contents, making it active, and then select Theme ->Table This will
display the attribute information currently within the shapefile.



CSISS - GIS Cookbook: Recipe - Joining a table

To get your shapefiles attribute table
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Your shapefiles attribute table

 There is usually only basic information. You will need to identify one of these attribute columns to match up
 your external data too. In this scenerio, we will be joining to counties. 

3) Navigate to and open your external data source. Open to the data you would like to add or join to the
shapefile open in ArcView. Your external data will need to be in the correct form to bring it into ArcView,
either (txt or .dbf) If you are working in excel see the recipe Importing an Excel table to your GIS project
(3.x) This recipe may work for other platforms as well.

4) In your external data, Make sure that there is a one to one match so that each data entry matches with
one shapefile attrubute. This will allow you to join the two together. This may require you to do some editing
of your external data source. You may have to combine or expand your data to fit the one to one
relationship.

 (For Example, if you wanted to join your external data to counties , but your external data was organized in
 census tracts or cities with county information within them, you would need to combine the information
 within the datasource so that there was only one county entry. You would add up all the cities or cesus
 tracts to make one county entry.)

5) When you are finished editing your data there should be the same number of data entries in your external
data as there are in row attributes (polygons, or ID numbers) in your shapefile attribute table. Make sure
you SAVE and CLOSE the external Data file you have been working on.

6) Now we will bring your external data into ArcView.
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7) Go to the project manager window. Then click on the table icon, and in the upper right corner, click Add

The Project Manager window

8) The Add Table window will appear.
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Load your external Data

 Navigate to the directory with your external data in it. Make sure that on the lower left of the Add Table
 window, that the List of File Type matches the type of your external data, either .dbf, .txt, or INFO. When
 you have selected your external data on the right side of the window, click Ok 

 If your error message says that the file is busy or already in use See Pitfall 1
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9) Your external data will appear in a table window in ArcView. Click on the column attribute that you plan to
join with your shapefile attribute.
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Your external data
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Select the attribute you will use to join the two

10) Now open the attribute table for the shapefile you are joining too and click on the matching column
attribute (the one field in two have in common)
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Select the matching attribute to join

11) With both column headings selected select Table -> Join
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Join the two

12) Your external data table will disappear. It is now joined to your shapefile. Now in the attribute table of
your shapefile you can scroll right and see your external table embedded within it. If you don't see it See
Pitfall 2or See Pitfall 3.
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Your final joined data, ready for analysis and so much more

13) It is now spatially referenced and can be used for spatial analysis. For example, See Recipe Making a
choropleth map (3.x)
Pitfalls:

This means that you have left the external data file you are trying to import open in another window. 
 Makes sure the file you are importing and preferably its host program are closed before you import 
 the data. Link
There are many possibilities for error when joining two features. The synatx of the two columns you  
are joining have to be exactly the same
If the join is successful, but there are some blank rows in the join, there maybe some errors in your 
 external data source, you need to go back through your external data source and compare it to the 
 attribute table of the shapefile until they match up exactly
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 GIS Cookbook: Recipe - Joining a table 

Keywords: Tables, joining, relates, sorting, data analysis
Category: Data Analysis
Software: ArcGIS 8/9.x

Problem: I have information in a table that I would like to join to a point, polygon or line layer.

Description: Often times, the information you want to display or analyze within GIS is in two different places or formats. Often you will
 have a map of a standard area, like the counties in a state or the states of a country, and you will want to add external data to them so
 you can look at that external data in a spatial context. In this recipe we will look at how to join data to a shapefile. 

Scenario:
 Ever since the work of John Snow and his mapping of Cholera cases, mapping cases and frequencies of diseases can help to find
 sources and cures. One of the major research topics of the 20th century is the search for an understanding of cancer. It helps
 researchers in the subject to know where the cases of cancer are the highest. In this scenario, we are going to look at the state of New
 Mexico and join the cancer statistics for each county to the counties within the state.

Methodology:
1) Open ArcMap.

2) Add the shapefile you wish to attach your data to.
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The Shapefile you are going to work with

3) Right-click on the shapefile and select Open Attribute Table This will display the tabular information currently within the shapefile.
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Opening the attribute table of the shapefile we are working with
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The New Mexico layer's attribute table

 You will need to identify one of these attribute columns to match up your external data too. In this scenario, we will be joining based on
 the NAME field. 

4) Ensure that your external data is in a form that is compatible with ArcMap, either delimited text or .dbf. If you are working in Excel see
the recipe Importing an Excel table to your GIS project (ArcGIS 8.x/9.x).

 Also, make sure that there is a one-to-one match between the records in the external data source and the shapefile attribute table. This
 will allow you to join the two tables together. This may require you to do some editing of your external data source. You may have to
 combine or expand your data to fit the one-to-one relationship. 

 (For example, if you wanted to join your external data to counties, but your external data was organized in census tracts or cities with
 county information within them, you would need to combine the information within the data source so that there was only one county
 entry. You would add up all the cities or census tracts to make one county entry.)

 When you are finished editing your data there should be the same number of data entries in your external data as there are in your
 shapefile attribute table. Make sure you SAVE and CLOSE the external data file you have been working on.

5) In ArcMap, go to the Add Data button. Navigate to your external dataset in either .txt or .dbf form. Select it and click Add

6) Your external data set will appear in the Table of Contents beneath your shapefile. Note: You can view external data tables like this
one by clicking on the Source tab at the bottom of the Table of Contents. The Display tab shows only the map layers in the map
document.

7) Right-click on your shapefile within the Table of Contents and select Joins and Relates -> Join . Note: This step is always
performed on the layer you want to join data TO.
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Joining

8) The Join Data window will appear. In Step 1, choose the name of the field in the shapefile you will use to join the data. In Step 2,
select your external data source. In Step 3, select the name of the field in your external data source that you are going to join by. Then
click OK .
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The Join Data Window

 If your error message says that the file is busy or already in use, See Pitfall 1

9) Right-click on the shapefile in the Table of Contents and select Open Attribute Table. Scroll to the right and confirm that the data
from the external table have been appended onto the original data. If not, See Pitfall 2.
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External Data is displayed in the attribute table of your original shapefile

10) Your external information is now spatially referenced and can be used for spatial analysis. For example, See Recipe Making a
choropleth map (8.x)
Pitfalls:

This means that you have left the external data file you are trying to import open in another application. Make sure the file you
 are importing and preferably its host program is closed before you import the data.
If the tables joined successfully, but there are empty cells where you expect valid values, it means the value in the join field for
 that record did not have a match in the external data. You should double-check to make sure you've selected the correct fields
 to perform the join.
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 GIS Cookbook: Recipe - Classifying Data 

Keywords: Census tract, census data, classification, reclassification, nominal data, interval data, null
 value
Category: Census Data
Software: ArcView 3.2

Problem: I have a shapefile of census tracts with attributes, how do I classify the data?

Description: When a shapefile is being displayed on your view, it is usually shown in a single color.
 This is because the information has not been classified into categories. When information has been
 classified by a given variable, the shapefile will display different colors representing different values for
 that variable in its attribute table. For example, if a census tract were to be displayed according to age,
 it may result in an image where red would stand for a tract with an average age above 60, orange for
 the 50 to 60 range, yellow for 40 to 49, and so on. When classifying data, you can choose the ranges in
 which your data will be divided. You are also able to select the colors that will be associated with each
 range, although it is important to keep your color scheme intuitive and easy to follow.

Scenario:
 In this recipe, you will learn how to classify and display census tracts according to average age within
 each tract.

Methodology:
1) Create a new view and add your census tract shapefile to your view by using the Add Data button

.
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2) Make the census tract theme active by clicking on it in your view window. Now select the Edit
Legend

 button. A window similar to the following should pop-up on your screen.
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3) In the space next to Theme should be the name of the census tract layer. For Legend Type we will
choose "Graduated Color." If you were to choose "Unique Color" a different and unrelated color would
be assigned to each category. "Unique color" should be used if you are classifying nominal data (i.e.
data that does not have an inherent order to it that would require an ordered color scheme to
accompany it). "Graduated Color" is being used here because we want to display the average age
within each tract. Age is interval data, so we want a color scheme that shows this order.

4) For Classification Field, select the category you would like to display. In this example we are using
Avg_age.

5) We do not need to normalize the data by any other category because we are only displaying one
attribute, therefore leave it as None. Your Legend Editor should look similar to the following picture.

6) Notice in the above picture, instead of beginning with 0, the first interval begins with -99. -99 is the
null value used in the database to stand for a missing value. These values should be excluded to avoid
skewing the image's color scale. To exclude the null value, press the null value button

 within the Legend Editor window. 
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7) Under Field choose the name of the category from which you would like to exclude the null value,
then type in the value in the following space below.

 Note: if you choose the "Include No Data Class in Legend" box, it will display the null value on your  
legend and label it as "no data."

 Select the OK button. Your legend editor should now exclude the null value from its first interval.

8) Select Apply at the bottom of the Legend Editor window. Notice if you do not like the color scheme or
the way it displays in the view window, select Undo and make the necessary changes. To change the
color scheme scroll down the Color Ramps option. Your View should now be classified.
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Pitfalls:

There should be no pitfalls, if any are found please contact us or refer to the links below

Links:

ESRI Canada (K-12) Tutorial - This is an ESRI tutorial page that talks about reclassifying census tracts  
within a geocoding tutorial. This recipe references this page.
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 GIS Cookbook: Recipe - Making a Choropleth map 

Keywords: Spatial analyisis, choropleth map, color symbology
Category: Data Analysis
Software: ArcView 3.2

Problem: How do I make a choropleth map, so I can see pattterns and analyze them.

Description: A choropleth map is a map that uses different colors to show different values over space. This
 is very helpful to look at different values displayed over space.

Scenario:
 Ever since the work of John Snow and his mapping of Cholera cases, mapping cases and frequencies of
 diseases can help to find sources and cures. One of the major research topics of the 20th century is the
 search for an understanding of cancer. It helps researchers in the subject to know where the cases of
 cancer are the highest. In this scenerio, we are going to look at the state of New Mexico the cancer
 statistics for each county. Once finish we can look at and analyse the information and compare it to other
 choropleth maps.

Methodology:
1) Open ArcView and add the layer/shapefile you want to work with.
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Your starting attribute

2) Click on the shapefile in the table of contents, making it active, and then select Theme ->Table This will
display the . If it is not, and you need to add it from an external source, see the recipe Joining a table (3.x)
Make sure to note the name of the column you are going to display.
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Open your attribute table
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Your shapefiles attribute table

3) Double click on the shapefile in the table of contents and your will appear
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Double click on your theme/shapefile to bring up the Legend Editor

4) In the second dialogue box in your legend editor, change the Legend Type: from Single Symbol to
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Select graduated color
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Graduated color selected

5) Now, in the third dialogue box Classification Field: select the Attribute column from your shapefile that you
wish do display in different categories, by highlighting it.
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Change to the attribute you want to map by

6) The preorganized classes for your choropleth map will appear.
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Your prearranged classes will appear

7) Now, within the window you can edit the colors (color ramps), number of classes (Classify button), your
class intervals (double click on the numbers themselves) and even the types of classifications(advanced,
classify button) you can use to display your map. To obtain the best results, it is best to use trial and error
when it comes to these details.
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You can easily change your color scheme

9) When the settings are tuned to your liking click Apply and then Ok

10) Your choropleth map will appear on your map window.
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Your Choropleth map the higher the number or darker the color the higher rate of cancer in that county

Authored by: Benjamin N. Sprague Modified: 9/11/03

Copyright © 2002-2015 by Regents of University of California, Santa Barbara
 Cookbook: Ben Sprague, Ethan Sundilson, Carlin Wong, Sam Ying



CSISS - GIS Cookbook: Recipe - Making a Choropleth Map

 GIS Cookbook: Recipe - Making a Choropleth Map 

Keywords: Spatial analysis, choropleth map, color symbology
Category: Data Analysis
Software: ArcGIS 8/9.x

Problem: How do I make a choropleth map, so I can see spatial patterns and analyze them?

Description: A choropleth map is a map that uses different colors to show how some phenomenon varies across space. For example,
 a choropleth map of U.S. states colored according to their population density (with light hues representing states with low population
 density and dark hues representing states with high population density) makes it easier to identify spatial patterns in the population
 data.

Scenario:
 Ever since the work of John Snow and his mapping of Cholera cases, mapping cases and frequencies of diseases can help to find
 sources and cures. One of the major research topics of the 20th century is the search for an understanding of cancer. It helps
 researchers in the subject to know where the cases of cancer are the highest. In this scenario, we are going to look at cancer statistics
 for each county in the state of New Mexico. Once finished we can look at and analyze the information and compare it to other
 choropleth maps.

Methodology:
1) Open ArcMap and add the shapefile that covers the desired study area in the desired areal units.
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Your starting shapefile/layer

2) Right-click on the layer/shapefile and select Open Attribute Table . This will display the tabular information currently within the
shapefile. Make sure the information you want to see is displayed within the attribute table. If it is not, and you need to add it from an
external source, see the recipe Joining a table . Make sure to note the name of the column you are going to display.
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Vew attribute table
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Your attribute table

3) Right-click on the shapefile and select Properties
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Layer properties

4) The Layer Properties window will appear. (If you have opened the properties for this shapefile before it will open to whichever
properties window you had opened last.)
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Layer Properties opened

5) On the top of the window click on the Symbology tab.

Symbology tab

6) On the left side of the dialog box under the Show: heading, select Quantities , then Graduated colors.
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Quantities selected

7) In the Fields section of the window , find the drop-down list labeled Value: . Select the attribute field from your shapefile that contains
the data you wish to use to construct the choropleth map.

Select your attribute

8) ArcMap will break your data up into five classes using the default Natural Breaks classification method and will assign a random light-
to-dark color ramp.
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What your choropleth classes will look like

9) Within the Layer Properties window you can now edit the colors (color ramp), number of classes, class intervals (click the Classify
button) and even the type of classification (also accessed through the Classify button).

10) When the settings are tuned to your liking click Apply and then OK

11) Your choropleth map will appear on your map window.
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Your choropleth map. Higher cases of cancer are darker, lower are lighter.
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 GIS Cookbook: Recipe - Define Projection for a Shapefile or Geodatabase 

Keywords: Projection, datum, coordinate, system, define, spheroid, shapefile, geodatabase, transform,
 ArcToolbox, wizard, unknown, 
Category: Projections
Software: ArcGIS 8.x

Problem: When I open my geographic data file, I get a warning message that the file does not have a
 coordinate system defined.

Description: Features on a three-dimensional spherical surface like the Earth are depicted on two-
dimensional surfaces like a paper map or computer screen using mathematical conversions known as
 map projections. All map projections distort real-world features in some way. A mnemonic that's often
 used to remember the four properties that could be distorted by a map projection is, "Projections make
 geographers SADD." (Shape, Area, Distance, Direction.)

 A valuable feature of ArcMap is something called “on-the-fly re-projection”, which means that the user
 can add datasets that are in different projections and ArcMap will make them line up in the same
 coordinate space. A critical element of this on-the-fly re-projection process is that each of the layers
 has its projection defined (i.e., that you, the user, tell the software how each layer is projected). Some
 of the datasets you come across will already have their projection defined. However, if when adding a
 dataset to ArcMap you receive a warning message or the layer does not line up with other layers, the
 dataset’s projection is either undefined or defined incorrectly. The solution is to properly define the
 projection using ArcToolbox (i.e., to tell the software how your data are projected).

 Note: The terms projection, coordinate system, and spatial reference are often used to refer to the
 same thing in the various ArcGIS dialog boxes. While there are slight differences between these terms,
 you can treat them as synonymous.

Methodology:
1) Start ArcToolbox from its location in your Start Menu hierarchy.
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The ArcToolbox window

2) There are four primary options in the toolbox: Analysis Tools, Conversion Tools, Data Management
Tools, and My Tools. Navigate to the Projections option underneath the Data Management Tools.

The various Data Management Tools, including projection tools

3) There are two Define Projection Wizards, one for coverages/grids/TINs and one for
shapefiles/geodatabases.
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The Projection tools

See Pitfall 1

 Double-click the Define Projection Wizard (shapefiles, geodatabases) option.

 In this example, we will use a traffic analysis zones file for the Sacramento Council of Governments
 planning area.
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The Define Projection Window

4) You are asked to select the data set for which you want to perform this operation. Using the Browse
button (or type the path and file) to the right of the select window, navigate to your data set. In this
case, the traffic analysis zones were selected.
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The Define Projection Window with the selcted file displayed

 Once selected, your data set should appear in the bottom half of the pop-up window. The right-hand
 side column displays the Coordinate System that has been defined for your data. If there is a
 coordinate system already defined, you're done. However, if you have not used this data set yet, it is
 likely that it says "Unknown". It is also possible that the GIS has assumed a coordinate system. If either
 you're coordinate system is unknown or assumed, you should proceed through the process of explicitly
 defining your coordinate system.

5) Select your data set in the window and click Next->.
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There is no coordinate system assigned yet

6) The next window shows the details of the coordinate system for your data. If no coordinate system
has been defined, it will be gray and blank. Click the button Select Coordinate System.
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Select the method of coordinate system assignment

 You are presented with several options on the Spatial Reference Properties window.

1. Select Select a pre-defined coordinate system. This is the most likely course of action. Your data is
probably in a common coordinate system that ESRI has included for you as pre-defined.
2. Import Import a coordinate system and X/Y/Z and M domains from an existing geodataset (e.g.,
feature dataset, feature class, raster). If you have another data set that you know has the same
projection, you can simply import that coordinate system here.
3. New Create a new coordinate system. In rare occasions, your data may have been projected in a
proprietary or uncommon coordinate system. This option allows you complete reign over the
components of the coordinate system definition.

See Pitfall 2

 In our example, a .txt file was included in the publicly available download from www.sacog.org that
 described the projection of the data (State Plane CA Zone II units feet Datum NAD83).
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7) So, we click Select

Starting the navigation to the proper coordinate system

 This takes us to a browse screen with two folders to browse: Projected Coordinate Systems and
 Geographic Coordinate Systems. Our coordinate system for the traffic zone data is a projected
 coordinate system.

8) Double-click the Projected Coordinate Systems or Geographic Coordinate Systems folder.

 Several options are available. Navigate through the folders until the desired coordinate system is
 located. For the example file, the State Plane folder is opened and then the NAD 1983 (Feet) folder,
 until a list of state plane projection options appears. For this example, we choose NAD 1983
 StatePlane California II FIPS 0402 (Feet).prj, since that is the projection identified in the .txt file that
 accompanied the data download.
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The proper coordinate system for our traffic zones data

9) Single-click the proper coordinate system and then click Add. You are returned to the previous
screen showing the chosen coordinate system and its details. Click OK.
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The Spatial Reference Properties window has been populated

10) Now the coordinate system details are waiting to be attached to your data set. Click Next.
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The Coordinate System has been attached

11) You are shown a final summary. Click Finish if you're satisfied.
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The final summary window

Pitfalls:

Don't know type of file.
Don't know the coordinate system for your data.

Sacramento Council of Governments data used in the example.
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 GIS Cookbook: Recipe - Define Projection for a Shapefile or Geodatabase 

Keywords: Projection, datum, coordinate system, define, spheroid, shapefile, geodatabase,
 ArcToolbox
Category: Projections
Software: ArcGIS 9.x

Problem: One of the layers in my map document is not lining up with the others OR When I add a
 dataset to ArcMap, I get a warning message that the data does not have a coordinate system defined.

Description: Features on a three-dimensional spherical surface like the Earth are depicted on two-
dimensional surfaces like a paper map or computer screen using mathematical conversions known as
 map projections. All map projections distort real-world features in some way. A mnemonic that's often
 used to remember the four properties that could be distorted by a map projection is, "Projections make
 geographers SADD." (Shape, Area, Distance, Direction.)

 A valuable feature of ArcMap is something called “on-the-fly re-projection”, which means that the user
 can add datasets that are in different projections and ArcMap will make them line up in the same
 coordinate space. A critical element of this on-the-fly re-projection process is that each of the layers
 has its projection defined (i.e., that you, the user, tell the software how each layer is projected). Some
 of the datasets you come across will already have their projection defined. However, if when adding a
 dataset to ArcMap you receive a warning message or the layer does not line up with other layers, the
 dataset’s projection is either undefined or defined incorrectly. The solution is to properly define the
 projection using ArcToolbox (i.e., to tell the software how your data are projected).

 Note: The terms projection, coordinate system, and spatial reference are often used to refer to the
 same thing in the various ArcGIS dialog boxes. While there are slight differences between these terms,
 you can treat them as synonymous.

Methodology:
 The biggest difference in defining a dataset's projection between ArcGIS 8.x and 9.x is that ArcToolbox
 is a stand-alone application in 8.x and is integrated into the ArcMap and ArcCatalog applications in 9.x. 

1) With either ArcMap or ArcCatalog open, click on the red toolbox icon on the Standard toolbar to open
ArcToolbox. Within the ArcMap application window, a pane that contains the ArcToolbox tools will be
added between the Table of Contents and map display area as shown below. The ArcToolbox window
will contain different toolboxes depending on which ArcGIS extensions are loaded on the computer.
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The ArcToolbox window

 Three of the more commonly used toolboxes are: Analysis Tools, Conversion Tools, and Data
 Management Tools.

2) Navigate to the Define Projection tool under Data Management Tools > Projections and
Transformations and double-click on it.
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Navigating to the Define Projection tool

3) In this example, we will use a shapefile of Pennsylvania census tracts downloaded from the Census
web site. Click on the Browse button to specify the Input Dataset or Feature Class.
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The Browse button on the Define Projection dialog box

 ArcMap will first check to see if the dataset already has its projection defined. If it doesn't, the program
 will then scan the dataset's coordinates to see if they all fall in the range of -180 to +180. If the
 coordinates are in that range, ArcMap will assume that the data are in latitude/longitude (also referred
 to as Geographic) coordinates. That is the case in this example.

 While the assumed projection may be correct, it is good practice to define the projection explicitly. 

4) Click the Properties button to define the dataset's projection.

The Properties button on the Define Projection dialog box

 The Spatial Reference Properties dialog box opens showing the projection properties of the dataset as
 it's currently defined. The dialog box provides three ways to define a dataset's projection:
1. Select: Select from a list of commonly used coordinate systems.
2. Import: Import the coordinate system definition from another dataset. Use when you know that your
dataset is in the same projection as another dataset.
3. New: Create a new coordinate system. On rare occasions, your data may have been projected in a
proprietary or uncommon coordinate system. This option allows you complete reign over the
components of the coordinate system definition.

 In this example, the Select option will be used. The coordinate system will be chosen to match the
 metadata information provided on the Census web site.

5) Click Select, then browse to the coordinate system through either the Geographic Coordinate
Systems or Projected Coordinate Systems folder. In this example, the desired coordinate system is
reached by navigating to Geographic Coordinate Systems > North America > North American
Datum 1983.prj.
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Browsing to the desired coordinate system

 Many of the commonly used coordinate systems such as the State Plane and UTM systems can be
 accessed through the Projected Coordinate Systems folder.

 Upon selecting the desired coordinate system, its detailed properties should appear in the Spatial
 Reference Properties dialog.

6) Click OK to dismiss the Spatial Reference Properties dialog. The name of the selected coordinate
system should now appear in the Define Projection dialog.

The Define Projection dialog after coordinate system is selected
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7) Click OK again to accept the selected coordinate system. A dialog box will report whether the
projection definition was assigned to the dataset properly. Click Close to dismiss this dialog.

 Note: Remember that this recipe is used simply to tell the software how a dataset is projected in cases 
 when that metadata is missing or incorrect. It is critical that ArcMap have correct projection information 
 for each data layer in order to perform on-the-fly re-projection. In some situations it is necessary to 
 permanently re-project a dataset from one coordinate system to another. See the Reprojecting data 
 recipe for details on this process. Links:
- 2000 Census Tracts Cartographic Boundary Files data used in the example .
- 2000 Census Tracts Cartographic Boundary Files Descriptions and Metadata used in this example.
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 GIS Cookbook: Recipe - Reprojecting Data 

Keywords: Projections, datums, coordinates, NAD, conic, match, conformal, planar, Robinson,
 geographic, azimuthal, cylindrical, longitude, latitude, Mercator, scale, skews, rotates, and shifts
 coverage, transform, geodata, spheroid
Category: Projections
Software: ArcView 3.2

Problem: The features on my map don't line up. Data occupies the same space in reality but is not
 displayed this way onscreen, how do I remedy this? ArcView 3.2

Description: Data from a spherical surface (Earth) can be displayed and distorted in numerous ways
 when placed on a flat surface, therefore the different ways of placing this data on the page are called
 projections. Geographic projections are different mathematical techniques to convert and portray 
 features from a spherical surface (Earth) onto a flat surface; each map projection has certain strengths
 and weaknesses in terms of accurately representing shape, area, distance, and direction. Projections
 must be altered to make data line up and to present it in the most geographically effective manner. 

Scenario:

 buffer

Methodology:
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The problem, the data doesn't line up.

1) Identify what projection your data is currently in if you have not already done so. To identify the
current projection, go to View->Properties.

2) Make sure your map units are set within View->Properties. If you get an error while setting
properties, See Pitfall 1.
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What Projection am I in

3) Open File->Extensions. Engage (i.e. check on) Projector. If you do not have Projector follow the
instructions after the next screenshot.
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 Here's how you can get Projector, a free and easy-to-use script, if you do not already have it:

1) Go to http://www.arcscripts.esri.com, then type "projector" into the search line and hit the
search button.

2) Select the ArcScript projector (which is authored by ESRI), click on it and select download.

3) Choose accept and download the file into your Ext32 folder, which itself is within your Av_gis
3.2 folder.

4) Open the Ext32 folder and unzip your downloaded file into it. You will notice one of the results
is a file with the ending .avx. This is your file extension.

5) If you have ArcView open, close it and then reopen it.

6) Choose File Extensions and click on the Projector extension.

http://www.arcscripts.esri.com/
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4) Close the extensions window and you will notice that a new icon appears on your ArcTools bar. If the
icon does not appear, go to See Pitfall 2.

5) To make the theme you want to reproject active, select the key for that theme and click the Projector
button

6) You will then be guided by a wizard, which will help you choose your units (usually defaulting to
meters), then choose which projection family and type you want or need to make your data match up
properly. If it is unclear how your data is currently projected, you may want to select a standard
projection for every theme, using the Projector tool for each. Finally, you will add the newly projected
data to whatever view you choose, then name the theme and store it in the appropriate directory.
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7) The result is that now all of the data is projected in the same manner (as shown below).
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Pitfalls:

1) This error message indicates you must change the map units to the units that you are working
with. In this example we are working with meters. If you are doing any distance calculations it is
generally good practice to change the distance units to meters also. To change these go to
View->Properties to find the map units and distance units pull-down bars.

2) If the Projector icon does not show up, exit out of ArcView entirely. Make sure the Projector
extension is in the active "ESRI Ext32" folder and it is unzipped. Then run ArcView and turn the
extension on. If it the extension still doesn't work, click here.

Authored by: Benjamin N. Sprague Modified: 9/10/03
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 GIS Cookbook: Recipe - Buffering an Area 

Keywords: Impact, assessment, government, buffer, analysis, regulations, influence, zone
Category: Buffers
Software: ArcView 3.2

Problem: To buffer an area of influence around an object at a specified distance

Description: A buffer refers to the area contained within a specified distance from an object in space.
 But why would we want to create one? 

Objects in space frequently have some sort of impact on the objects and areas around them. For
 example, factories emit fumes that can affect people for miles around. Freeways create "noise
 pollution" that can be heard blocks away. Buffers can be used in these instances to depict a sphere of
 influence in which the people and places within this "sphere" are more significantly impacted by a
 given phenomenon than those on the outside.

Buffers can also be used to show the reverse -- that is places that are less significantly impacted by a
 given phenomenon because they are within a certain distance of an object. These sorts of buffers,
 known as zones of protection, are frequently drawn in relation to regulations attempting to provide
 protection for special places. Examples include areas around school where liquor stores are prohibited,
 or protected lands around which shopping malls and urban development are not permitted.

Scenario:
 A story appearing in the Los Angeles Times provides an illustration of how buffers can be used to
 analyze and solve problems.1 The article explained that Irvine Medical Center had found it necessary to
 reject many of its indigent patients due to a shortage of available hosptial beds. In order to make this
 adjustment, UCI Medical Center decided to map a five-mile discrete buffer around the hospital, along
 with a two-mile buffer around the UCI-owned Family Health Centers in Anaheim and Santa Ana,
 California. In order to display this, buffers were created around the care centers. (In this example we
 are creating buffers around point features, but buffers can also be done on lines, and areas). When
 these buffers are in place, indigent people living outside of these buffers will be turned away. 

1 "UC Hospital Capping Indigent Care." Los Angeles Times, August 1, 2002.
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Methodology:
1) Start up ArcView and open a new view.

2) Add the themes that you would like to use in your view for analysis. For information on adding
data/themes see How to Add Data after opening a New View in the Getting Started section.

http://csiss.ncgia.ucsb.edu/cookbook/starter/13
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3) Perform queries as necessary to limit your data to relevant areas. By performing queries you are
simplifying your data into data relevant to your project. For example, in the illustration below, by
entering [State_name]="California" you are selecting only cities in California. Because the buffers to be
created only lie in California this query is helpful.

 If you are getting a syntax error message on your queries, See Pitfall 1. 

http://csiss.org/cookbook/glossary.php?term=Buffer
http://csiss.org/cookbook/glossary.php?term=Query
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4) After you have selected the points, lines, and areas of interest in your project, you need to convert
them to shapefiles. To do this, go to Theme->Convert to Shapefile. After you have created new
shapefiles, you can delete unnecessary themes selecting those themes are clicking Edit->Delete
themes.

5) Next, double click the themes in your view that you want to edit and now you can change the font,
style, and symbol of themes. (In this example, the care centers were given hospital cross symbols,
hospitals were changed to red to stand out on the yellow California background, and highways were
given highway markers). Now you have a view with themes that are ready to buffer.

6) To create a buffer for your selected theme, go to Theme->Create Buffers; in our case we would
select the care centers. The buffer wizard will first ask if you want multiple rings or one ring around the
geographic area that you want to buffer. This is an important consideration, because sometimes a
phenomenon tapers off with increasing distance from an object, rather than ending abruptly at the
outside boundary. Multiple buffers allow us to factor in levels of gradation that would be invisible when
using a single buffer. In our example, however, the care centers wish to draw a boundary that
separates those indigents who are eligible from using the their services from those who are not, so a
single, abrupt boundary for each is justified.
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7) Next provide the distance units to use and the distance to include in your buffer. (Be sure that the
distance units used in your view matches the distance units specified for the buffer. If you need to
change the view distance units go to View->Properties). Here, miles were used as the distance units,
as the map is of a relatively large scale. (Smaller distance units should be used when using smaller
scale maps). Next specify whether or not to dissolve barriers in the buffer. (Choosing to dissolve
barriers will unite that theme's buffered zones into one area. Conversely, choosing not to disolve
barriers, will give each new buffer a discrete area). Finally, add completed buffer as a new theme in
order to add data to your view. (To change colors on the display, go to CSISS Cookbook section
Cartographic Design.)
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 If you have specified multiple rings and only one buffer ring is shown, See Pitfall 2

8) To make your buffer rings transparent, first bring up the Legend+Editor class=term>Legend Editor
by double clicking on the theme. Then double click the symbol to open the pallete. Select the middle
pallete on the left side. Next click the paintbrush symbol and choose any color foreground that you
want along with no background. Click Apply.

http://csiss.org/cookbook/glossary.php?term=Buffer
http://csiss.org/cookbook/glossary.php?term=Buffer
http://csiss.org/cookbook/glossary.php?term=Legend
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9) To label themes, with the theme selected go to Theme->Auto-label... .
Select the field that you want to label and check themes text label placement property. You can move
the labels around by clicking on the map and dragging each individual label.

 If you are unable to label a certain theme, See Pitfall 3

10) In this example, people affected by the buffers are people living outside of the influence buffer.
Because of this, a good application would be to select the cities that are found just outside of the buffer.
In order to do this, you would first click the Select Feature tool and choose the cities that you want to

http://csiss.org/cookbook/glossary.php?term=Buffer
http://csiss.org/cookbook/glossary.php?term=Buffer
http://csiss.org/cookbook/glossary.php?term=Buffer
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 select. After you have done this, Convert to Shapefile... and add it to your view. To get a description of
 each point, you would use the identify tool to see the attributes of each point. (Another way to select
 cities that are close to the buffered zone, is to make another buffer(s) around the existing buffers. 

11) Again, add labels as needed. To create a map go to View->Layout. Edit your title, legend,
Scale+Bar class=term>scale bar, north arrow, and neatline(s) to make the map more dynamic.

12) Finally, export your map to a format that suits your needs such as jpeg or bitmap. To do this go to
 File->Export....

http://csiss.org/cookbook/glossary.php?term=Identify+tool
http://csiss.org/cookbook/glossary.php?term=Attribute
http://csiss.org/cookbook/glossary.php?term=Buffer
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Pitfalls:

1) If you receive a syntax error on your queries you are not giving your query in the correct form.
For example, you may be missing a parentheses or having a spelling error. An easy way to
eliminate the very common parenthesis problem is to query values one at a time, and after each
one clicking Add to Set. This will cut down on the number of parenthesis used and thus will give
less errors. Link

2) If only one ring is shown, you must specify on the legend editor that you want graduated color
as your legend type. In addition, you need to have buffer distance as your classification field in
order to display the buffer. Link

3) If you are unable to label a certain theme, it is probably because the theme that you are trying
to label does not contain a field in its associated attribute table that contains labels that can be
put on a map. For example, the new buffer theme will only contain two fields before editing,
namely shape and buffer distance. To be able to label theme areas, you must use a theme that
contains fields that can be used for labeling such as the field "city name."

Authored by: Ethan Sundilson Modified: 9/17/03

Copyright © 2002-2015 by Regents of University of California, Santa Barbara
 Cookbook: Ben Sprague, Ethan Sundilson, Carlin Wong, Sam Ying

http://www.geog.ubc.ca/courses/klink/gis.notes/ncgia/u05.html#SEC5.5.2
http://www.geographynetwork.com/
http://www.esri.com/


CSISS - GIS Cookbook: Recipe - Buffering an Area

 GIS Cookbook: Recipe - Buffering an Area 

Keywords: Buffers, impact, assessment
Category: Buffers
Software: ArcGIS 8.x

Problem: You want to an area of influence around an object at a given distance.

Description: A buffer refers to the area contained within a specified distance from an 
 in space. But why would we want to create one? 

 Objects in space frequently have some sort of impact on the objects and areas around them. For example,
 factories emit fumes that can affect people for miles around. Freeways create "noise pollution" that can be
 heard blocks away. Buffers can be used in these instances to depict a sphere of influence in which the
 people and places within this "sphere" are more significantly impacted by a given phenomenon than those
 on the outside.

 Buffers can also be used to show the reverse -- that is places that are less significantly impacted by a given
 phenomenon because they are within a certain distance of an object. These sorts of buffers, known as
 zones of protection, are frequently drawn in relation to regulations attempting to provide protection for
 special places. Examples include areas around school where liquor stores are prohibited, or protected lands
 around which shopping malls and urban development are not permitted.

Methodology:
1) Open ArcMap.

2) Add your datasets. If you need assistance with adding your data, see Add Data.

3) Click to hightlight the that contains the
to be buffered.

To .

Enter the fields and unique values.
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Note: Be sure the correct layer is being used and that Create a New Selection is set as the method. 

 Click Apply.

4) Return to the same layer in the display window and right click on this layer.

 Scroll down to Selection, then to Create Layer From Selected Features.

5) Go to Tools and scroll down to Buffer Wizard.
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Note: Be sure the newly created layer is being used

-Click Next.

6) The buffers are created according to one of three options: 1) at a specified distance; 2) based on a
distance from an attribute; or 3) as multiple buffer rings.

7) Select a Buffer Distance.

8) Click Next.

9) Choose whether to between buffers.
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10) Enter an output name under Specify output shapefile or
.

11) Click Finish.

Authored by: Carlin Wong Modified: 9/10/03
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 GIS Cookbook: Recipe - Buffering an Area 

Keywords: Buffers, impact, assessment
Category: Buffers
Software: ArcGIS 9.x

Problem: You want to an area of influence around an object at a given distance.

Description: A buffer refers to the area contained within a specified distance from an 
 in space. But why would we want to create one? 

 Objects in space frequently have some sort of impact on the objects and areas around them. For example,
 factories emit fumes that can affect people for miles around. Freeways create "noise pollution" that can be
 heard blocks away. Buffers can be used in these instances to depict a sphere of influence in which the
 people and places within this "sphere" are more significantly impacted by a given phenomenon than those
 on the outside.

 Buffers can also be used to show the reverse -- that is places that are less significantly impacted by a given
 phenomenon because they are within a certain distance of an object. These sorts of buffers, known as
 zones of protection, are frequently drawn in relation to regulations attempting to provide protection for
 special places. Examples include areas around school where liquor stores are prohibited, or protected lands
 around which shopping malls and urban development are not permitted.

Methodology:
1) Open ArcMap.

2) Add your datasets. If you need assistance with adding your data, see Add Data.

3) Click to hightlight the that contains the
to be buffered.

To .

Enter the fields and unique values.
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Note: Be sure the correct layer is being used and that Create a New Selection is set as the method. 

 Click Apply.

4) Return to the same layer in the display window and right click on this layer.

 Scroll down to Selection, then to Create Layer From Selected Features.

5) Go to Tools and scroll down to Buffer Wizard.
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Note: Be sure the newly created layer is being used

-Click Next.

6) The buffers are created according to one of three options: 1) at a specified distance; 2) based on a
distance from an attribute; or 3) as multiple buffer rings.

7) Select a Buffer Distance.

8) Click Next.

9) Choose whether to between buffers.
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10) Enter an output name under Specify output shapefile or
.

11) Click Finish.

Authored by: Jim Detwiler Modified: 11/9/04
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 GIS Cookbook: Recipe - How to Geocode Addresses 

Keywords: Geoprocessing, geocode, geocoding, address, address matching, street, zip, zone, address 
 number, street name, location, address table
Category: Geocoding
Software: ArcView 3.2

Problem: I have a list of patients' addresses. How do I plot their locations on a map?

Description: buffers and density estimation.

Scenario:
 A fictitious epidemiological study taking place in Atlanta, Georgia, will be used as the example for this recipe. A 
 sociologist working with an emergency room doctor is trying to see if there are any patterns in the distribution 
 of children who enter emergency rooms with fevers. The research group is prepared with an Excel DBF4 table  
of the patients' home addresses and a street network of Atlanta as their reference theme feature onto which 
the addresses will be geocoded. Their table of addresses is far from perfect and this recipe will guide you  
through the different pitfalls one might encounter when geocoding.

Methodology:
1) Open a New View and use the Add Data button

 to add your reference theme feature (in this case, it is the street network of Atlanta, GA) After we added the
 street network, the view now looks like this:
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2) Go to the project window and click on Tables.

 Click Add and navigate to .dbf (the suffix for database files) file of address. Below is a screen shot of the .dbf
 we are using. Fields in the database include the patient record number, the patient address, zip code,
 symptoms when entering the emergency room, and the patient age. 

3) Make the View1 window active by clicking on it. Go to the main menu bar and click View->Geocode
Addresses. The Geocode Addresses window should pop up. Fill in the fields following the field labels.
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 Remember to select in which folder you would like to save your new geocoded address shapefile. Click the
 Folder button 

 and navigate to the appropriate directory (it may be helpful to save your new file in the same folder as your
 .dbf, but this is not required). 
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 After you have selected your file location, click the Batch Match button 

4) A window showing your geocoding results will pop up.

 Because of errors in your address database, in this case it was in the patient1.dbf, you will get Partial or No
 Matches. Partial matches occur when the address record appears partially on the reference theme (e.g. the
 street name is correct, but the address number does not fit what is available in the reference theme). No
 Matches occur when there are gross spelling mistakes where the program cannot recognize the name, or
 other mistakes that would cause the reference theme to not recognize the address at all within the options in
 the reference theme. Information about these scenarios is included in the ArcView 3.2 Help Menu.

5) In this example we were able to match all addresses in the patient.dbf file except for one partial match and
three that did not match anything at all. To view why the addresses did not match, click the Interactive
Re-match button

6) The Geocoding Editor should appear.
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 The editor displays the address shown in .dbf file of address, and below that, show the closest options
 available within the reference theme. You can either change your address entry if you find there is a mistake,
 or you can select one of the addresses the editor gives you. In this case, a 0 has been omitted from the
 address number. So we will change it from "167 W Peachtree" to "1670 W Peachtree". 

 After you are done with the adjustments, click the Match button. 

7) After selecting Match, the editor will search through the reference theme once more and give you a new list
of options. Usually, if there is a match, the correct one will be highlighted in yellow.
After you are done, click the Done button.

8) The Geocode Editor will then return you to the Re-Match Address Window showing you have now resolve
the partial match address.
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 Next to Re-Match, scroll down the menu to select the No-Match option. Repeat the same procedure you
 executed with the partial matches to find the correct matches. Select Done when you have corrected all the
 un-matched addresses. If you are still having problems, See Pitfall 1.

9) After you have matched all the addresses correctly, the Re-match Address window should show 100%
matches.

 Click Done.

10) Within your View1, there should now be the added geocoded address theme. Click the box next to your
new theme's name for the theme to display your geocoded points.

11) To change the look of your points, please see CSISS Cookbook section Cartographic Design.
Pitfalls:

1) A partial or no match result can be due to one of several mistakes. If your address has not been
entered in the standard format (i.e. address number, street name, street type, and direction), you may
get an error result. Extreme misspellings of street names (usually involving four or more incorrect
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 letters) will cause a no match result. You can lower the spelling sensitivity (and thus give more leeway
 for typos) by going to the preference menu on the Re-match Address window. In addition, pairing an
 Incorrect zip code with a correct address will cause a no match result.
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 GIS Cookbook: Recipe - How to Geocode Addresses 

Keywords: Geocoding, geocoding services, geoprocessing, geodatabase, address matching, address number, locations,
 representations, reference theme, street, street name, zones, zip code 
Category: Geocoding
Software: ArcGIS 8/9.x

Problem: I have a list of locations of armed robberies, how do I display these locations onto a map?

Description: Geocoding is the process of matching a particular address with a geographic location. This is done through
 matching records in two databases, one containing a list of addresses, the other containing information about a street
 network. The geocoding tool will match a given address with its unique position within the street network. Since the street
 network will already have been located in geographic space with reference to some coordinate system, assigning a given
 address on the street network also has the effect of locating that address in geographic space as well.

Scenario:
 A criminologist wants to map the reported cases of armed robberies on businesses in Atlanta, Georgia, in order to reveal
 spatial patterns in the robbery data that may shed new light on the phenomenon. Such information can be used to predict
 future crimes or even as evidence against a known suspect. The criminologist is working with two files. One is a table of
 victimized business addresses and the other is an Atlanta, Georgia street shapefile.

Methodology:
 The geocoding in this recipe will be done in ArcCatalog. Note that geocoding can also be done in ArcMap (Tools >
 Geocode Addresses).

1) Open ArcCatalog.

2) Find the address table you want to geocode.
See Pitfall 1

Note: The table icon should look similar to this.
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Note: When opened, the table should contain an address field similar to the one in the example above.

3) Right-click on this table and select Geocode Addresses.

4) Select a geocoding service to use, then click OK.
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Choosing a geocoding style.

-If no services are shown, then click Browse for service.

-If the desired geocoding services are still unavailable, they must be created. See "Creating a Geocoding
Service/Address Locator".

5) In the Geocode Addresses window, the Address Input Fields should have been automatically set based on the geocoding
service. If not, click on the dropdown list to choose the name of the column that has the correct address attribute.
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6) Under Output shapefile or feature class click on the folder button to navigate to the folder in which you want to save your
output file. Name this file, then click Save.
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7) Click Advanced Geometry Options if you want to set the output coordinate system to something other than the
coordinate system used by the reference (street) data.

8) Click Geocoding Options if you want to modify the settings used to match addresses to the street database. See
"Creating a Geocoding Service/Address Locator" for more information on these settings.

See Pitfall 2



CSISS - GIS Cookbook: Recipe - How to Geocode Addresses

9) Click OK on the Geocode Addresses window to begin the address matching process.

10) After processing, a window will report the address matching results and provide an opportunity to re-process unmatched
or poorly matched addresses.
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11) Clicking the Match Interactively button opens a window that allows you to review the unmatched addresses one at a
time. The unmatched addresses are shown in the upper half of the window. The selected address is highlighted in blue. The
way the software parsed the selected address into individual address components is shown in the middle of the window and
candidate street segment matches are shown at the bottom. If there is an obvious mistake in the way the address has been
parsed, click the Modify button to fix the mistake. After fixing the mistake, an updated list of candidate street segments
should appear. If one of these candidates is an acceptable match (note the Score value, with 100 being a perfect score),
highlight the street segment and click Match.

12) Repeat the review process for each unmatched address, then click Close.

13) Click Done to finish the geocoding session.

14) To display your geocoded result, open ArcMap and add this file. Here is an example of the final product.
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Note: The green points are the geocoded addresses.

Pitfalls:

1) Giving a street the wrong suffix or street type, like "Court" instead of "Avenue," or providing no suffix when there
are multiple streets with the same name in the database, will cause errors. Misspelled street names or street names
not in the database can also cause errors, although the software will try to match abbreviations and account for
possible misspellings. This can be adjusted in the Geocoding Options window. It is also possible that there are errors
or outdated information within the street database itself that could cause additional errors.
2) Street addresses are estimated along block faces; therefore, the true locations of the addresses may not be
represented. For example, an address with a house number of 50 will be placed exactly halfway along the 0-100
block even though the actual location of the house is not likely to be at the exact midpoint of the street segment.
Also, pay close attention to the offset setting (i.e., the distance from the street centerline the addresses will be
placed). The offset can be adjusted in the Geocoding Options window.
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 GIS Cookbook: Recipe - Selecting From Geocoded Addresses 

Keywords: Geocoding, query, query builder, select from set, new set, add to set
Category: Geocoding
Software: ArcView 3.2

Problem: I have geocoded a table of addresses (see recipe Geocoding a database of addresses), how
 can I select all of the restaurants?

Description: After a table of addresses has been geocoded, often times the user needs to attribute
 table would be very time consuming. 

Scenario:
 After geocoding a list of address of local commercial buildings, a city planner would like to locate all the
 restaurants in the area. This recipe will show users how to build a query using the Query Builder. This
 recipe will also allow users to learn the difference between the Add to Set, Select from Set, and New
 Set options within the Query Builder.

Methodology:
1) A list of addresses that have been geocoded may look similar to the picture below, taking the
example from the recipe Geocoding a database of addresses.

 Click the  button to use the Query Builder.
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2) Highlight the attribute table.

 NOTE: To learn about what each function is within the Query builder refer to the Help Menu within
 ArcView 3.2. Click on Help, select Help Topics, select the Index tab, type "query builder".

3) In this example, we would like to query the locations of all the restaurants within the geocoded layer.
We will build a simple query to accomplish this task.

 To begin, we double-click on the option [Type] in the left hand column; in our example it separates the
 businesses in our database into various categories. Next, click on the = sign, which will link our
 business type to a given value. We will select that value from the set of choices in the right-hand
 column by double-clicking on the word "Restaurant". Spaces will be automatically placed into your
 query, which appears in the space below the function buttons. Be careful about altering the spaces
 within your query; you may be surprised by a errors in processing your query. (See Pitfall 1.)
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 Select Add to set. Your view should now have the locations of all restaurants highlighted in yellow.

4) Suppose now you would like to select all the cafes also. Delete the old query and enter a new query
in the same format as used to query the restaurant locations except double click "cafes" instead of
"restaurants" .

 Your query should look similar to the following:

 If you would like to ADD the locations of the cafes to your already highlighted locations of restaurants
 select the Add to Set button. If you would like to clear the restaurant selections and ONLY have the
 cafes, select the New Set button. 
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5) The Select from Set button lets the user query for something within the already highlighted choices.
For example, below, the planner has selected all the cafes and restaurants and would like to select
within that set, all restaurants and cafes within a certain zip code. The following query displays how to
build a query to perform this task.

 Now click the Select from Set button. Your results should be narrowed down to only the locations
 within that zip code zone.

Pitfalls:

1) Syntax errors may be faced when building queries. To see suggestions on how to correct the
syntax of your query, go to the following links, or go to the help file and type query builder

Links:

http://support.esri.com/forums/
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ESRI tutorial - ESRI's tutorial for K-12 (this recipe references this page)
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 GIS Cookbook: Cartographic Design - Preparing your map for presentation (without
 using a template) 

Keywords: Presentation, finishing, printing, cartographic elements, layouts
Category: Cartographic Design
Software: ArcView 3.2

Problem: How do I prepare my data for presentation without using a template? 

Description: You are satisfied with the data in your MapView window and would like to move the map into a layout
 form to prepare my map for presentation or printing. 
Note: Preparing your map without a template allows you to fine tune your map to your own style without following any
 pre-set guidelines, however, it may be more time consuming. 

Methodology:
1) Note the name of the View window that contains the data you would like to present. On the following image, the View
window is titled "United States."
2) To create a layout file, click on the Layouts Icon on the project manager window.
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Project Manager Window is shown on the left side of this image. Note that the layouts icon is highlighted.

3) Now that you have highlighted the Layouts icon, click the New button on the top of the project manager window.

4) A new window will open and should look similar to the following image.
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Main Layout Window

5) To specify the size and orientation of the paper you are using to print your map select Layout ->Page Setup
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Layout -> Page Setup

6a) The Page Setup window will appear. 

Page Setup window
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 Enter the dimensions of your printing paper under Page Size. 
Note: The maximum paper size you are able to use is usually determined by the type of printer.

6b) Now choose the orientation of the paper you would like to use. 

6c) When you have made all your selections click Ok.

7) Then click on the earth shaped icon,

 your cursor should change to a plus sign shape.

8) Move your mouse to the area of the layout page where you would like to place your data image. While keeping your
mouse down, drag the mouse diagonally. Release the mouse button when the square is the size you want your image.
Note: Make sure you leave room for a title, scale bar, and the other cartographic elements.

Location of the map

9) The view frame Properties window will appear after you release the mouse button.
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View Properties window

 Select the view you wish to display. Make sure to uncheck the live link box so that your view will be preserved even if
 you alter the view window. Take note of the scale in case you want to include it in your map credits later. Then click
 OK

10) Your map should appear in the box you created.
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Ready to add more

 Now you are ready to add other information (e.g. title, scale bar, north arrow, credits, etc.) to your map.
Note: You may also want to include more than one map view in your final layout. To do so follow the above steps
 again. Unless you are making the second map a locator map, too many maps in one layout may confuse the user.
 Links:
Making Maps with GIS - Getting Started with Geographic Information Systems 
Prof. Keith Clarke's Home Page - Links to help with selected topics in geography and cartography
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 GIS Cookbook: Cartographic Design - Preparing your map for presentation (without using a template) 

Keywords: Presentation, map, layout, printing
Category: Cartographic Design
Software: ArcInfo 8

Problem: How do I prepare my data for presentation?

Description: You are satisfied with the data in your Data View window and would like to move the map into a layout form for presentation or printing.

Methodology:
1) To prepare your data for presentation first make sure that you want to display all the data frames and all the turned on data you have in your table of contents.
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http://csiss.org/cookbook/design/24[8/25/2015 1:22:32 PM]

I want to display this.

2) Before proceeding you need to determine how large you want your map presentation to be. So select File ->Page Setup
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Page Setup

3) Choose the size of your paper, keep in mind that many sizes require special printers, so do not select a size that cannot be handled by your printer. You can also choose here
whether you want a portrait or landscape format.
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Page Setup Window
 When you have made your selections click ok
4) To get to a layout, select View -> Layout View
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Changing to the layout view

5) You layout view will appear with your data frame windows centered in the middle of the layout page.
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Both Data frames are shown

6) Organize the map windows in the size and location you would like them (Note: If you would only like to display one of them you can move the dataframe you don't want to
display out of the way



CSISS - GIS Cookbook: Cartographic Design - Preparing your map for presentation (without using a template)



CSISS - GIS Cookbook: Cartographic Design - Preparing your map for presentation (without using a template)

Just select it and move it out of the way

 , or you can turn off the themes which you do not want to display. 
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Turn the individual themes off
,
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Themes off

7) Now you are ready to add the other Cartographic Elements.
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http://csiss.org/cookbook/design/14[8/25/2015 1:22:35 PM]

 GIS Cookbook: Cartographic Design - Shortcut to preparing your map for presentation (using a
 template) 

Keywords: Presentation, finishing, printing, cartographic elements, layouts, 
Category: Cartographic Design
Software: ArcView 3.2

Problem: How do I quickly prepare my map for presentation (or printing)?

Description: You are satisfied with the data in your MapView window and would like to move the map into a layout form for
 presentation or printing.

Methodology:
1) Highlight the window (by clicking on it) that is displaying the data (map) you would like to prepare for presentation

Highlight your map by clicking on the image or the title bar
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2) Adding cartographic elements such as a legend or north arrow are done in the layout window, select View -> Layout

3) When the Template Manager window appears, choose the page layout you would like to use.

Template Manager Window

Note: You are only given a limited number of options in the template mode, to expand these options see Moving your map
 into the presentation stage (without using the template) recipe. Click on the layout you would like to use then click Ok 
4) Select New Layout from the View-Layout window and click Ok
5) Your new layout will appear with a scale bar, a legend, a neatline, a title and a north arrow. You can edit each of these by
double clicking on them.
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Your resulting templated layout

6) For more information on how to edit selected cartographic elements including scale bar, legend, neatline, title, and north
arrow, see the corresponding recipes.
7) If you would like your final print out to include more than one map on a single page, refer to the recipe titled Moving your
map into the presentation stage (without using the template). Links:
Prof. Keith Clarke's Home Page - Links to help with selected topics in geography and cartography
Getting Started with Geographic Information Systems - Introduction to GIS and basic help with making maps
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 GIS Cookbook: Cartographic Design - Shortcut to preparing your map for presentation (using a template) 

Keywords: Presentation, map, layout, printing
Category: Cartographic Design
Software: ArcInfo 8

Problem: How do I quickly, neatly prepare my data for presentation or printing?

Description: You are satisfied with the data in your Data View window and want to move the map into a layout form for the effective presentation of information.

Methodology:
1) To prepare your data for presentation first make sure that you want to display all the data frame you have in your table of contents.
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This is what i want to display.

2) To get to a layout, select View -> Layout View
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Getting to the Layout View

3) You layout view will appear with your data frame windows centered in the middle of the layout page.
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Layout View

4) To use a templated layout , click on the Change Layout Button



CSISS - GIS Cookbook: Cartographic Design - Shortcut to preparing your map for presentation (using a template)



CSISS - GIS Cookbook: Cartographic Design - Shortcut to preparing your map for presentation (using a template)

Change Layout Button

5) The Select Template Wizard window will appear.

Layout Wizard, Simply follow the instructions

6) Choose the tab and the template you would like for your map. (Note: If you have more then one map in your data frames you can choose to display one or all of them simply
follow the prompted instructions.)
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7) When you have finished selecting all your preferences, simply click Finish

8) Your map layout will appear with the basic cartographic elements embedded within them.
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Enter in the final touches

 Some elements will require further detail, such as in the case with text, you will be prompted with text saying Simply double click and add your title or text. 

9) If you are unhappy with some of the organization of your map you can click on the object (ie. North Arrow, Legend, Scale Bar) that you would like to move and simply drag it
where you would like it.

10) You are now ready to print your map layout. If you wish to personalize your map layout further see the other recipes within the Cartographic Design Section
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 GIS Cookbook: Cartographic Design - Creating a Report 

Keywords: Report, chart, extension, display
Category: Buffers
Software: ArcView 3.2

Problem: I have map data and I would like to present it in a report.

Description: An easy way to create a report of data from themes is to create a report using the Report Writer
 extension. The extension will allow you to produce a report of specific fields of a theme in minutes.

Scenario:
 Building on the scenario Buffering an Area recipe, you now want to make a report of the cities that are most
 affected by the buffers around the Irvine Medical Center and Family Health Centers.

Methodology:
1) Go to File->Extensions and put a check by the Report Writer extension.

2) Select the theme in your view for which you wish to write a report.

http://csiss.ncgia.ucsb.edu/cookbook/recipe/1
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3) Go to Theme->Create a Report. You will need Quick Report checked. Next click on the amount of records
that you would like to use in your report (All or Selected Records). Click Finish.

4) Next you will need to designate which fields you would like to use in your report. You can also set the font
and spacing of the report and margins. Finally, you are now ready to print your report.
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 If you are having problems printing to your specifications, See Pitfall 1.

 If you are having trouble viewing or saving your report digitally, See Pitfall 2.

Pitfalls:

1) In order to change the printer options, you must first preview your report. The Preview option is found
at the bottom of the Layout tab where you selected what fields need to be in the report. When you have
selected the Preview option, click the button that shows a printer and a wrench symbol. Now you can
change the paper size, and specify the printer that you want to use.

 Link

2) To save your report in a specific format, first you will need to preview it. To save, click the button that
looks like an envelope. You will then choose the format you would like to save it as. (Saving it as a
Microsoft Word document makes it very easy to view.) Finally, specify that your destination will be a disk
file and click Save.

Links:
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 GIS Cookbook: Cartographic Design - Adding and Editing a Legend to a Layout 

Keywords: Presentation, finishing, printing, cartographic elements, layouts, legends, symbols, defining
Category: Cartographic Design
Software: ArcView 3.2

Problem: How do I add a legend to my map?

Description: Your map is in the Layout format and you would like to add a legend.
Note: For help on getting your map into the Layout format, refer to recipe Shortcut to moving your map into the
 presentation stage (using a template)

Methodology:
1) Click and hold the last button on the layout tool bar.

Legend Tool

2) Select the Legend icon

3) While holding down the mouse button, drag the cursor over to where you would like to place the legend.
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Selecting a location for your legend

 Release the button when the square shows the appropriate size for your map. The square indicates the size of the
 legend you are creating.

4) The Legend Frame Properties window will appear.

Legend Frame Properties window

 Select the view within which you would like to display your legend. 

5) Your legend should appear in the selected location on your map. The name of each layer of data used in creating
your map will automatically be used within the legend labels.

6) To change the graphics and text of your legend click on the legend so that dark squares appear on all four corners.
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Legend selected

7) Go to the menu item Graphics-->Simplify .
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Simplify

 This will change the legend object from one object to a number of individual objects (i.e., ungrouping). You can then
 move, delete, add, or change the individual legend elements to match your presenation style. You may also change
 the text font and symbols used within the legend.
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Ungrouped objects after simplify tool

 You may also decide to add or delete certain elements from your legend that may not be necessary to include in your
 presenation. Click on each unwanted element then press Delete.
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Editing your legend

8) To alter the font and size of your legend text, or the specifics of your symbol simply press Control P while the object
you wish to alter is selected and then choose your palette properties. You can also edit the content of your text by
double cliking on the text object you would like to change.

Changing the text in your legend
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Note: To learn more about editing text refer to the recipe Adding text to a layout 

9) Once you have configured the individual legend elements to your own standards you must re-group the elements.
Select all the elements you would like in the legend. Then select the menu item Graphics-->Group.

Grouping the objects in your legend to one object

 All of the selected elements will re-group into one object. You can go back and forth by ungrouping and grouping
 objects, editing and reediting them until you are satisfied with your presentation. 
Note: Once you have simplified and grouped for the first time, use Graphics-> Ungroup and Graphics-> Group to edit
 your legend. The Simplify command is only used the first time.
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 GIS Cookbook: Cartographic Design - Adding and Editing a Legend 

Keywords: Presentation, legend, display properties, definition, printing, cartographic elements, symbols
Category: Cartographic Design
Software: ArcInfo 8

Problem: How do I add a legend to my map?

Description: Your map is inthe Layout format and you would like to add a legend.
Note: For help on getting your map into the Layout format, refer to recipe Shortcut to moving your map into the presentation stage (using a template)

Methodology:
1) In the layout view window, make sure the dataframe you want to work with is selected by clicking on the dataframe name. We would like to add a legend that includes the
information for the United States dataframe, so we would click on the name "United States" to highlight it. Then select Insert -> Legend
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Inserting a legend

2) The Legend Wizard window will pop up. Follow the steps to create your legend. First choose the specific symbols from the table of contents that you want to use in the legend.
Note:If the themes from the wrong data frame appear in the your legend wizard window, See Pitfall 1.
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Legend Wizard (Choose the information you want displayed)

4) Now add a title and an outline by selecting the style and shape of the legend symbols presented to you in the legend wizard. You may also want to change the spacing within
the legend.
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Enter a title in the text area
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Choose the styles of borders. If you do not want a border you may select a blank pattern.
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Change the way certain elements are represented on your map.
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Choosing the spacing between your legend elements.

5) Once you have finished personalizing your legend, click Finish

6) Your legend should appear on your map layout. You can then drag it by clicking on it, and holding down the mouse button, then moving the cursor to where you would like to
place the legend.
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Your legend will appear, click and drag it to its final destination.

7) You may want to further edit your legend to change the names of features or delete certain text or symbols. To edit make these additional changes RIGHT CLICK on the
legend and select Convert to graphics. By doing this you will make the legend into an image independent of the map and make your necessary changes on the legend without it
influencing your map.
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Convert to Graphics

8) To edit the pieces of your legend individually, right click on the legend and select Ungroup
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Ungroup the Graphics

9) The individual pieces of your legend will then each become highlighted and selected.
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The resulting Ungrouped Graphics

 Click on them individually to edit them. 
Note: You may have to ungroup some parts of the legend more then once to edit the more detailed elements.

Personalized map legend

10) Be sure to re-group the elements by right clicking on the legend and selecting Regroup when you are finished modifying the individual elements within the legend.
Pitfalls:

Press cancel to exit the window and activate the dataframe that includes the information you would like to use for your legend.
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 GIS Cookbook: Cartographic Design - Adding a Scale bar to a Layout 

Keywords: Presentation, map scale, scale bar, distance, printing
Category: Cartographic Design
Software: ArcView 3.2

Problem: How do I add a scale bar to my map?

Description: Your map is in the Layout format and you would like to add a scale bar.
Note:For help on getting your map into the Layout format, refer to recipe Shortcut to moving your map into the
 presentation stage (using a template)

Methodology:
1) Click and hold the last button on the Layout tool bar.

Selecting the scale bar tool

2) Select the Scale Bar icon

3) While holding down the mouse button, drag the cursor over to where you would like to place the scale bar.
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Selecting the appropriate location for your scale bar

 Release the button when the rectangle shows the appropriate size. The rectangle indicates the size of the scale bar
 you are creating.

4) After releasing the mouse button the Scale Bar Properties menu will appear.

Scale Bar Properties window
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 Select the View within which you would the to display the scale bar. If your view does not appear please See Pitfall 1)
 Select the style and map units you would like and click ok

5) Your north arrow should appear in the selected location on your map.

Pitfalls:

If your view does not appear you must set the units (meters, feet, miles, etc.) of your view for your map. To
 select a unit measurement for your map go to the Views section of the project manager window and select
 View->Properties . Select the map units you would like to use using the distance units pull down bars.
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 GIS Cookbook: Cartographic Design - Adding a scale bar to your layout 

Keywords: Presentation, map scale, scale bar, distance, printing
Category: Cartographic Design
Software: ArcInfo 8

Problem: How do I add a scale bar to my map?

Description: Your map is in the Layout window, now you would like to add a scale bar.

Methodology:
1) In your layout view highlight the data frame that includes the data layers to which you would like to add a scale bar. To select it click on it once. 

Select your the data feature you want to display

Note: If the wrong data frame is selected then your scale will have incorrect measurements.

2) Then select Insert -> Scale Bar 
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Insert a scale bar

3) The Scale Bar Selector window will appear. Choose the style you would like to use for your scale bar.
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Scale bar selector

4) You can further change the specifics of your scale bar by clicking the Properties button. 

5) When you have made all your selections click Ok .

6) You scale bar will appear in the center of your map layout. 
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 You can then resize it and drag to the desired location on your map layout.
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7) You can further change the scale bar by double clicking on it and following the menu commands.
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 GIS Cookbook: Cartographic Design - Adding a Neatline or Borders to a Layout 

Keywords: Presentation, finishing, printing, cartographic elements, layouts, borders, outlines 
Category: Cartographic Design
Software: ArcView 3.2

Problem: How do I add a border to my map?

Description: Your map is in the Layout format and you would like to add a border.
Note:For help on getting your map into the Layout format, refer to recipe Shortcut to moving your map into the
 presentation stage (using a template)

Methodology:
1) Select the object or objects you would like to include within the border. If you would like the border to surround the
entire presentation area (i.e., Neatline), do not select anything. This should be your last step before printing.

Finding the Neatline icon

2) Select the Neatline Button

3) The Neatline Settings window will appear.
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Neatline Settings window

 Select the appropriate styles and details for your border. Suggestion: Use the Inset from Margins selection if you would
 like to place a border around all map elements. 

4) When you are finished click ok and the map border will appear.
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5) To add another border select the object or objects you would like to include within the second border and repeat the
above steps.
Note: Finding the appropriate settings for your border requires trial and error and also depends on your presentation
style.
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 GIS Cookbook: Cartographic Design - Adding a Neatline or a border to your map layout. 

Keywords: Presentation, border, frame, neatline, printing
Category: Cartographic Design
Software: ArcInfo 8

Problem: How do I add a border to my map?

Description: Your map is in the layout window, now you would like to add a border or borders around or within the map.

Methodology:
1) In your layout window, select the object or objects you would like a border around. If you would like to place a border around the entire
 presentation area (i.e. a neatline), make sure that nothing in your layout has been is selected/highlighted.
Note: Adding a neatline is usually the last step before printing.

Neatline Manager Window

2) In the layout window, select Insert -> Neatline . 
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Your newly added neatline and background color

3) The Neatline window will come up

The layout to which you would like to add a neatline

4) Select the appropriate styles and details for your border. If you would like a default selection, use the Inset from Margins selection if you want a
 border/Neatline around your whole presentation. 

5) You can also choose a background color and a drop shadow. 
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6) When you are finished selecting the different options, click Ok and your border should appear. Like all steps in preparing a presentation, finding
 the correct settings for your border requires trial and error.

7) You can further change the border/neatline by double clicking on it and following the menu options.
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 GIS Cookbook: Cartographic Design - Automatically Labeling your Map 

Keywords: Presentation, map, labels, place names, identification, batch, layout
Category: Cartographic Design
Software: ArcView 3.2

Problem: How do I add labels to my map?

Description: You would like to add text labels to all the objects in one or more of your data layers. In this recipe,
 labels will be added automatically displaying the text in your attribute table.

Methodology:
1) Make sure your map is the set to the zoom of your liking before proceeding. Changing the zoom on your map after
you add labels may change the size and placement of the labels.

2) Click on the theme to which you would like to add labels. In the following image, the theme called "Ocean" has
been selected. To highlight the theme "US States," we clicked on it with the mouse.

U.S. States theme legend not selected.

 Notice below the "US States" theme has now been highlighted.
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U.S. States theme legend selected.

3) Select Theme -> Autolabel.
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Theme -> Auto Label.

4) The Auto-label window will appear.

Label Field window.

 To choose your label names, click on the pull down menu for Label field at the top of the window. Here we have
 chosen the attribute column titled "State_abbr." 

Note: If there are no options in the Label Field window See Pitfall 1.

5) Once you have selected all the appropriate settings click Ok .

6) Labels should appear on your map on the appropriate places.
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Notice the green labels are overlapping. It may be helpful to alter the size of the font being used.

7) If you are not satified with the appearence of the labels, you can edit all your labels at once by first selecting all of
them by keeping your mouse button down and highlighting the entire labeled area.
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Selecting all the labels allows you to change their display all at once.

8) Then to change the font style, size, or color, press Control P and choose your new text properties from the pop-up
Palette window.
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Now the labels are presented at a more appropriate size.

 If your labels do not fit the screen properly, it is helpful to choose a smaller font size.
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After resizing your labels, it may be necessary to move your labels back into the proper location.

 If you would like to move the labels, click once on the label you'd like to move and four black square should appear
 around the label text.
 Click and hold, then drag to move the labels to a new location. Repeat this process to move the labels over one by
 one. 

9) There are a few other properties that you may want to change to fit the style of your presenation. To see the other
options, double click on one of the labels and the Text Properties menu should appear. After you are done, click OK.

Pitfalls:

When the scroll down menu has no options it indicates that there are no columns in your attribute table that
 are appropriate for use in labeling. You must enter in each label one at a time. Please refer to the recipe Refer
 to the recipe Adding individual labels to your map.
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 GIS Cookbook: Cartographic Design - Adding Individual Labels to your Map 

Keywords: Presentation, map, labels, place names, identification, objects
Category: Cartographic Design
Software: ArcView 3.2

Problem: How do I add individual labels to my map?

Description: You would like to add text labels to one or more objects within one or more of your data layers. In this
 recipe, you will be adding labels on one at a time. To see alternatives to adding labels to your map, please refer to
 recipe Automatically Labeling your Map.

Methodology:
1) Make sure your map is the set to the zoom of your liking before proceeding. Changing the zoom on your map after
you add labels may change the size and placement of the labels.

2) Click on the theme to which you would like to add labels. In the following image, the theme called "Ocean" has
been selected. To highlight the theme "US States," we clicked on it with the mouse.

U.S. States theme legend NOT selected

 Notice below the "US States" theme has been highlighted.
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U.S. States theme legend selected

3) Click on the label tool menu (button with a tag on it). A drop down menu of all the label shapes and styles will
appear. Click on the one that best suites your map style. The cursor will take the shape of a plus (+) sign after you
select a label style.

4) Select the place on the map which you would like to label. Click on that area with the plus (+) sign cursor.
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5) Use your arrow to move the labels around one by one. Click once on the label to select it. Four black dots will
appear around it signifying that you can edit the label. To change the style of the text such as the font, size, or color
press Control P while the text you wish to alter is highlighted and then choose your new text properties.

6) You can also change the angle at which the label is displayed and the actual label text content after labeling. To do
this double click on the label and the Text Properties will appear. Follow the menu options to change the elements.

Pitfalls:

To change the attribute you are going to display as the label on the map, follow the directions in the recipe
 Automatically adding Labels to your Map , at the appropriate step choose the label field you want. Click Ok
 . After all the labels show up simply select them all delete them (or select Theme -> Remove Labels ) and
 then follow directions in this recipe.
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 GIS Cookbook: Cartographic Design - Adding a North Arrow to your Map Layout. 

Keywords: Presentation, north arrow, printing, map elements
Category: Cartographic Design
Software: ArcView 3.2

Problem: How do I add a North arrow to my map? 

Description: Your map is in the Layout format and you would like to add a north arrow.
Note:For help on getting your map into the Layout format, refer to recipe Shortcut to moving your map into the
 presentation stage (using a template)

Methodology:
1) Click and hold the last button on the layout tool bar.

Finding the north arrow menu

2) Select the North Arrow icon

3) Drag the cursor over page area you would like filled by the North Arrow, while holding down the mouse button.
Release the button when the square is approximately the size you want it.
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4) The North Arrow Manager window will appear after you release the mouse button. Select the style of north arrow you
would like to use and then click Ok

Selelcting the size and area for the north arrow
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5) Your north arrow will appear in your map layout. You can alter it by double clicking on it and following the menu
options.

North arrow added onto the layout
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 GIS Cookbook: Cartographic Design - Adding a North Arrow to your Map Layout 

Keywords: Presentation, layout, north arrow, reference, printing
Category: Cartographic Design
Software: ArcInfo 8

Problem: How do I add a north arrow? 

Description: Your map is in the layout window, now you would like to add a north arrow.

Methodology:
1) In your Layout view, select Insert -> North Arrow 

Insert the north arrow into your layout

2) The North Arrow Manager window will come up. Choose a style for your north arrow. 
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North arrow selector window

3) You can change the style of your north arrow by clicking the Properties button. 

4) When you have made all your selections click Ok .

5) You north arrow will appear in the center of your map layout. 



CSISS - GIS Cookbook: Cartographic Design - Adding a North Arrow to your Map Layout

The result

 You can then resize it and drag it to the desired location on your map layout.
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Move and resize to your liking

6) You can further change the north arrow by double clicking on it.
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 GIS Cookbook: Cartographic Design - Adding Text or a Title to a Layout 

Keywords: Presentation, finishing, printing, cartographic elements, layouts, text, title, captions
Category: Cartographic Design
Software: ArcView 3.2

Problem: How do I add text to my map?

Description: Your map is in the Layout format and you would like to add some text (e.g. title, credits, date,
 etc.).
Note:For help on getting your map into the Layout format, refer to recipe Shortcut to moving your map
 into the presentation stage (using a template)

Methodology:
1) In the Layout view, click and hold the third to last button on the layout tool bar, this will access the text
menu.

Text Icon Toolbar

2) Select the Text Button of your choice.

3) Now use the cursor and click on the area to which you would like to add text.

4) The Text Properties window will appear. Type the text you would like to disply in the window and click Ok .
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Text Properties Window

5) To change the size, color, and/or font of the text, highlight the text with your mouse and then hold down
Control P to bring up the palette window.

Text Palette

 Now modify the text to your liking using the palette tools. If you have the correct text selected, but the text
 color will not change when you click to change it using the palette, please refer to See Pitfall 1 
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Text Palette Color Pitfall

6) You should now be able to see text in the style you chose from the palette. Now you may move the text to
the appropriate location by clicking on the text box, holding down the mouse button, and dragging it to the
desired location on your map.

Text inserted
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7) You can repeat these steps as many times as you'd like.

Note: You can edit your text or change the angle your text is displayed by double clicking on the text itself.
Pitfalls:

Pitfall 1: Make sure that you have selected text in the color pull down menu, not background or
 others.
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 GIS Cookbook: Cartographic Design - Adding a title or other text to your layout. 

Keywords: Presentation, layout, printing, title, text 
Category: Cartographic Design
Software: ArcInfo 8

Problem: How do I add text to my map?

Description: Your map is in the layout window, now you want to add text such as a title, captions, etc.

Methodology:
1) In the Layout view, select Insert -> Text or (see below figure)

Insert -> Title. Both selections will essentially accomplish the same task.
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2) A box will appear in the middle of your layout page with highlighted text saying Enter text/title here 

 Double click on this box and the properties window will appear.
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3) Enter your text here.

4) To change the font and size of your text click Change Symbol .

5) Then move your title to where you would like it by clicking on the text box, holding your left mouse button down, and dragging the text box to the
 desired location.
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6) You can further change the text by double clicking on it and following the menu commands.
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 GIS Cookbook: Background - Background Information about Geocoding 

Keywords: geoprocessing, geocode, geocoding, address, address matching, street, zip, zone, address
 number, street name, location, address table, Extended 911, geolocating, condominium, apartment, multi-unit
 complex, Japan addres
Category: Geocoding
Software: ArcView 3.2

Background: Geocoding in the simplest terms is "the act of assigning locations to things within the
 geographic frame of reference" (Goodchild, 2001). Geocoding has many synonyms including georeferencing
 and geolocating. The key to a georeferencing system is that each location has a unique code. This is possible
 only to a certain limit because of the overwhelming amount of information that would be needed for all things
 to have a unique code in the reference frame of the entire globe. Commonly, address number with street
 address and zip code are used to locate buildings within a reference frame. Street direction (i.e. north, east,
 south, or west) and street type (e.g. street, avenue, boulevard, etc.) may also be added to increase the
 precision of the output. Addresses are inputted in a tabular form and then matched with a geocoded reference
 theme. The reference theme is a digital map that has all the locations geocoded and can be displayed
 graphically or in tabular form. The reference theme includes many categories of information about each street
 location by listing street name, city name, zip code, the range of numbers on the right and left side of the
 street, street type, and street direction. Geocoding is not only limited to street addresses, for a less precise
 geocoding process, one can use only the zoning description, such as zip code or zoning number assigned by
 the city zoning ordinance. Different types of codes used for differentiating one location from another can be
 used to geocode within ArcGIS 8 by selecting a specific geocoding service.

Pros: There are many advantages to using the geocoding tool within a GIS. It can be applied in numerous
 social science fields and makes spatial analysis much more efficient. After a researcher has attained the
 necessary data to make a geocoded map (the database file of addresses and a geocoded reference theme),
 processing and producing the final geocoded address map may take as little as twenty minutes. After all the
 addresses have been mapped, one can do pattern analysis and many other types of spatial analysis.

The images above show a table of addresses (upper right) being geocoded using the reference theme (upper left) to create the final map on the
 bottom (center).
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Cons: There a few disadvantages to geocoding with addresses. A drawback is the lack of uniqueness of each
 location as the area of interest gets bigger. Almost every city has a street called "Main Street." To avoid this
 problem one can assign more precise descriptors as mentioned above, such as direction or street type.

 Many problems arise when working with rural areas. The street address numbers are given as a range of
 number on either side of a road and are assumed to be evenly spaced apart. This becomes very inaccurate in
 rural areas where the distances between houses vary considerably. Many rural addresses are just labeled as
 rural delivery route numbers, but sequential numbering on houses is increasingly common because of
 Extended "911", which mandates local governments to re-number their rural addresses in the interests of
 improving emergency response (Goodchild, 2002). 

 When geocoding addresses that are within high-density areas, one can experience problems similar to
 geocoding rural addresses. Structures such as condominiums, apartments, and other multi-unit complexes do
 not always have addresses ordered sequentially along roads. Also, within some apartment complexes of
 multiple buildings, some streets are not named, causing another confusion as to how to give each address a
 unique set of information.

 When viewing the results of a geocoded list of addresses, one should be aware of the level of precision and
 accuracy of the end product. Geocoding gives the coordinates of the building as being directly lined up at the
 street whereas in real life, some structures may be set back very far from the road, such as if a house or
 business had a very long driveway. 
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 GIS Cookbook: Background - Background Information about Buffers 

Keywords: Buffer, points, lines, polygons, raster, vector, topography
Category: Buffers
Software: ArcView 3.2

Background: When buffering, the user creates a new object that displays and identifies which areas
 are found within a specified distance of the original object. The buffer operation results in new
 boundaries around points, lines, or polygons.

*Examples of buffers are listed in the description section of the recipe*
A common concern among people using buffers is figuring out what buffer width to use in their map or
analysis. Because buffer width designation can vary substantially between projects, various factors
could be used. These factors include:

1) Input from the Source: An attribute of the object being buffered is used to determine buffer width. For
example, buffer width could depend on the amount of chemical spilled from a refinery

2) Internal Factors Within a Buffer: Variables affecting the area inside the buffer boundaries such as
topography within the buffer and weather conditions. eg. If the object being buffered lies where annual
winds blow out of the east, the buffer distance around the object will probably be greater to the west of
the object

3) Outcomes: What is probably going to happen because of variables inside and or outside the buffered
area. An example would be if certain populated areas are given priority evacuation due to the chemical
spill

Pros: There are many advantages to using buffers in GIS. First of all, buffers can be applied to both
 vector and raster data, which is abnormal for most GIS operations. A buffer made in raster format is
 unlike one made in vector. In vector a new object is formed in the shape of a buffer, however in raster,
 cells are merely classified to whether they are inside or outside the buffer zone. A good example of a
 raster application is shown below with travel times.
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Another advantage to using buffers in GIS is the ability to use multiple rings for varying buffer distances.
 Because of this, if you want to show that certain distances have more impact than others you do not
 need to create several buffers. Finally, two other advantages specific to ArcMap include the ability to
 buffer coverages, and the choice of whether to round area, or line buffer edges. These advantages add
 precision to your results.

Cons: There are few disadvantages for using buffers in Arc View and Arc Info. One disadvantage
 however, is of topography. When buffering at a certain distance you are measuring that distance as the
 crow flies and you are not taking in account the differing slope of the land. For example if regions to the
 east of the point, line or area being buffered have a high slope and regions to the west have minimal
 elevation increase, your buffered regions will cover different total areas on each side. But when you
 specify a buffer distance such as ten miles, ten miles will not take in account slope, and thus may skew
 results.
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 GIS Cookbook: Background - Background Information about Presentations
 and Finishing 

Keywords: Presentation, Cartographic design, finishing, details professional, layout
Category: Datums
Software: ArcView 3.2

Background: A map can be defined as a graphic depiction of all or part of a geographic realm in which
 the real world features have been replaced by symbols. (Clarke, 2001) 

 Once you have created, analyzed, and altered the content of your map to your satisfaction. It is time to
 make a layout which will put your map into context and explain its content and significance to the map
 reader. It is important that the map layout be a self contained unit, it should be self explanatory even
 when it is being used to supplement another document. Therefore your main map image needs to be
 supplemented by certain cartographic elements to make the map self sufficient. The main cartographic
 elements are; the title, neatline, scale bar, legend, inset map, and north arrow.
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The Cartographic Elements (Clarke, 2001)

 It is important to include all the Cartographic elements to make your map presentation complete. Adding 
 all the Cartographic elements will give the map reader all the information he or she needs to understand 
 the map and its context. This will complete your map presentation. After this you will be ready to print 
 and present your map. 

 NOTE: (There are many nuances and specifics to map presentations, who your target audience is, what 
your goal is etc.). There is a plethora of literature on map presentation and the best way to go about it.  
These recipes are just a simple, get it done quick, guide to presenting your map. We suggest you do  
some outside reading if you want to maximize the effectiveness of your map presentation. Hope this  
helps)

 If this is your first time using the presentation features of your mapping software, we highly recommend 
 that you read chapter 7 of Getting Started with Geographic Information Systems, by Keith Clarke
 (Prentice Hall, 2001). 

Pros: The presentation packages provided in ArcView 3.2 are useful tools for the presentation of your 
 spatially referenced information to a larger audience. You can provide all the information needed to 
 make your map presentation a useful tool. Large presentation size maps posters can be developed 
 incorporating everything from tables to charts, graphics maps and images. Furthermore the presentation 
 of your information in a spatial context will add credibility to your research by putting within real world 
 scale and context. Adding of the different cartographic elements make the map entirely accessible to 
 the map reader.

Cons: The presentation part of this package is very comprehensive. However this creates a problem. It 
 is very difficult to come up with an error free presentation. There is always room for improvement. It is 
 easy to have too much, or too little information. It is also easy to have a ineffective presentation due to  
cartographic inconsistencies. E.g. Having attention drawn to the wrong elements, having somethings  too 
big and others to small, or too light or too dark etc.  The only solution to this problem is trial and  error. So 
keep at it and you will come up with a great presentation.
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Address matching - Address matching is the process of assigning x, y coordinates to addresses so they can be
 displayed as points on a map. This process allows two or more data files to be related using a common address
 field.
Attribute - A trait or characteristic of a feature on a map. For example, attributes of a county may include its area,
 perimeter, name, total population, etc. Attributes can be viewed through the attribute table such as within a
 shapefile.
Attribute table - A table that is attached to a data layer that contains many characteristics of a feature on a map.
 The table is made of columns and rows where the columns represent values or description for different attributes
 and each row represents a different feature. For example, the attribute table for a layer of points that represents
 elementary schools may have columns labeled “number of students,” “number of teachers,” or “distance from
 police station,” and each row would represent a different school having values for each column.
Buffer - A buffer is a region around a geographic area (point, line or polygon). Buffers are usually used for
 proximity analysis. Buffers can be created in both ArcView, and ArcInfo
Cartographic Elements - One of the building blocks that make up a map from which all maps must be
 assembled. (Clarke, 2001) See Figure below.

Database management system - A DBMS is a collection of computer programs and software for organizing the
 information in a database. A DBMS supports the structuring of the database in a standard format and provides
 tools for data input, verification, storage, retrieval, query, and manipulation.
Dissolve Barriers - An option in the buffer wizard to treat a soon to be created buffer as either one object or
 several
Feature - A digital representation of something in the real world. For example, dots or points on a map layer may
 represent the location of schools, a line may represent a river, and a polygon may represent the outline of an
 area such as a county.
Feature class - Feature classes are classifications and representations of geographic features and supporting
 data in coverages. Feature classes represented as geographic features include points, arcs, nodes, route-
systems, routes, sections, polygons, and regions. They can also store annotations, dimensions, x, y, z
 coordinates, and addresses. Feature classes can be found in a feature dataset where the same coordinate
 system can be shared and organized into a geometric network that can maintain topological relationships
 between its feature classes. Feature classes can also exist independently in the geodatabase.
Feature dataset - A feature dataset is a collection of feature classes sharing the same spatial reference. These
 feature classes can take part in topological relationships with each other such as in a geometric network. Feature
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 datasets can also store object classes and relationship classes.
Geocoding - Geocoding is also commonly known as address matching. It is the process of creating a spatial
 description of a place, such as a point feature from a nonspatial description of that place, like a street address.
 Recorded x, y coordinates of a location are cross-referencing between a standard reference grid and non-
geographic data such as addresses or zip codes to accurately map that location. In order to geocode, a
 geocoding service must first be defined.
Geocoding service - A geocoding service defines a procedure for changing non-spatial descriptions of places
 into spatial descriptions. These services define paths to reference data, rules for standardizing alphanumeric
 descriptions of locations and matching them to the reference data, and parameters for reading address data and
 creating output. Geocoding services can be used to find individual addresses and to geocode tables of
 addresses. Geocoding tables of addresses allow a user to review and rematch feature classes and shapefiles.
Geodatabase - Geodatabase stands for geographic database and stores geographic information inside a DBMS
 or database management system. A geodatabase supports advanced capabilities such as geometric and logical
 networks, true curves, complex polylines, and user-defined features. They are the modern equivalents of
 shapefiles and coverages stored in a DBMS. Geodatabases support large collections of objects in a database
 table and features with geometry. The feature classes and tables contained in geodatabases can be related to
 one another. In order to define the relationships between objects in a geodatabase, a relationship class must first
 be created. These relationships allow someone to use attributes stored in a related object to symbolize, label, or
 query a feature class.
Geoprocessing - Geoprocessing embodies GIS operations, which include data conversion, geographic feature
 overlays, topology processing, coverage selection and analysis.
Graduated Color - Graduated Color Features are features that are displayed with the same symbol type, but the
 colors on each represent the progression of values for a data attribute you specify
Identify tool - The Identify tool lets you display the attributes of features on a view by clicking on them with the
 mouse. Attributes of all features located at the same point are displayed
Layer - A collection of similar geographic features within a particular area that is defined by the map display. An
 example of a layer may be a map of only rivers within a state. There are different types of layers (also called data
 layers) such as shapefiles, coverages, or grids. These data layers show different types of representations of the
 real world and can be accessed and managed like other types of data within your database.
Layout - A layout is a map that lets you display views, charts, tables, imported graphics, and graphic primitives.
 The layout is used to prepare these graphics for output from ArcView or ArcInfo. A layout defines what data will
 be used for output and how they will be displayed
Legend - Translates the symbols on the map into words by locating text and the symbols close to each other in
 the page coordinate space. (Clarke, 2001)
Legend Editor - A menu that allows you to choose the legend type for a specific theme. (graduated color,
 graduated symbol, single symbol, unique value, or chart). It also allows you to change the font, style, fill color,
 thickness of the points, lines or areas of your theme
Locator Map - Also known as an inset map, is an enlarged or reduced map designed to put the main map into
 geographic context, or to enlarge the area of interest whose level of detail is to specific for the main map scale.
 The locator map should have all the cartographic elements but at a highly simplified format. (Clarke, 2001)
Neatline - Is the visual frame for the map. It is a border around the entire page. It usually provides the basis for a
 the page. (Clarke, 2001)
Object - A set of points, lines or polygons in a spatial database that represent a real-world entity. These can be
 manipulated, and counted in a GIS, and are represented in a GIS as shapefiles
Query - A question or request used for selecting features. A query usually appears in the form of a statement or
 logical expression. It can contain a field, an operator, and a value.
Relational database management system - A database management system with the ability to access data
 organized in tabular files that can be related to each other by a common field. An RDBMS can recombine the
 data items from different files, providing powerful tools for data usage. RDBMS services include validation rules,
 relationships, and topological associations.
Rematching - A re-geocoding of a subset of addresses (which can included all or fewer than the original set of
 addressed) of features in a geocoded feature class. Rematching is done when partial or unmatched records
 result when geocoding address with errors such as misspellings or other data entry errors.
Scale - The distance ratio measured on a map to that distance measured on the ground between the same two
 points. For example if one cm on a map equals 1,000,000 cm in the real world the map scale would be
 1:1,000,000. This scale of 1:1,000,000 on the map would be considered small scale compared to a map with a
 scale of 1:1,000
Scale Bar - Is a visual expression of the relationship between ground coordinate space and that if the map page
 space. (Clarke, 2001)
Select feature tool - The Select Feature tool lets you select features with the mouse by pointing at them or by
 dragging a selection box over them. Features that fall partly or wholly inside the box you define will be selected.
 Features will be selected from all of the currently active themes
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